How to get rid of EDT(-04:00) in invitation templates


when i send invitation through the calendar, the dynamic field “date” pulls up the EDT time . i do not want it and i do not know how to get rid of it

can anyone explain?

Also in email templates, i am unable to pull up the last name and first name of my leads. I get this in the email invitations:

$lead_first_name $lead_last_name,

and the names are not replaced

What is your SuiteCRM version? I believe that problem with the variables not getting replaced is already fixed in 7.10.7…

Do you know you can customize this file?

Create a corresponding file in the “custom” directory and edit it.

Hi. I have the latest version:

Version 7.10.7
Sugar Version 6.5.25

You’re right, it is not completely solved, and the fix hasn’t been shipped yet.

There is something here

and there are a few related issues, you can keep an eye on them.

About the date, please check the timezone setting for your CLI (command-line) PHP. This is what cron is using, so the notifications will get the timezone setting from it. Note that this is different from the setting you have inside SuiteCRM, and in your web server’s php.ini.

Try these from a command-line:

To see effective CLI timezone setting:

php -i | grep timezone

To see the path of the CLI php.ini:

php -i | grep php.ini

Hi thanks but I do not understand your solution. My server administrator neither. what is the crm script or settings should I change ?


I also have the american date showing instead of european format despite having change the local timezone settings in the backend

Tell me the results of those two commands I gave you.

And the path that the second command gives, edit that file and correct the date.timezone setting inside it.

Then restart web server.

I do not understand how to make a command. its a shared hosting

please explain

You mentioned you had a “server administrator”, I hope he knows how to enter commands? :slight_smile:

You should be able to access your shared hosting via SSH, that’s where you enter commands. If your shared hosting doesn’t allow SSH access (or another equivalent shell access) then I would say you need to consider changing your hosting. I don’t think it’s a good idea to try and run a CRM without being able to reach your OS.

Hi. I dont have my own server administrator. it s a shared hosting, which means there is no access to ssh

so how to get the right date format since the crm script is buggy and does not take into account the local time zone setting from the backend ?

spending days on this… annoying

I put date.timezone = Europe/Paris in my php.ini but it did not fix the problem

There are many shared hostings out there with SSH access (limited to your area of course, but enough to work with). I really cannot recommend trying to use SuiteCRM without some decent administrative access.

SuiteCRM is a complex, multi-layered app that writes itself when you customize it. It has inevitable demands for Administrative care, things like file permissions and CLI PHP access, which are not very complicated, but if your hosting is too restrictive, then it is not adequate for SuiteCRM.

If you don’t have access to the CLI php.ini, which is the one used by scripts launched by crontab, which is what the Scheduler Jobs use (for example, meeting invitations), then sorry, you can’t set the timezone.

The CRM script is emphatically not buggy in this regard. This is the way Linux works, and the way PHP works. There are two different php.ini’s, one for the web app, the other from command-line (CLI), and there is no way that the web app can change a setting for the CLI.