How to disable auto-refresh in all the users dashlets

I’m experiencing some performance problems and I suspects many users has auto-refresh with 30 seconds in some dashlets and I’m getting a lot of slot queries in prime time.

Anybody knows some trick to reset the auto-refresh in dashlets to “do not auto-refresh” in the meantime I solve the performance problems?

1 Like

Hey @isaacmarco,

The only way I could see this working without causing a loss of user preferences would be to create a custom script executed on the application.

Above shows, the preferences functions which if called correctly could override the saved data in the DB table user_preferences the data in which is encoded and not displayed in plain text. Hopefully, with some luck, you’ll be able to find a solution to this issue :+1:

Thank you @Mac-Rae,

I think I found a better place. You can put this in your config_override.php

$sugar_config['dashlet_auto_refresh_min'] = '-1';

and the next time every dashlet is refreshed it will be the last time and the dropdown selector to adjust the autorefresh in the dashlet won’t be showed to the user.

A quick repair is not required.


Every days a day for learning, that one is getting added to the list of tricks :grinning_face_with_smiling_eyes: :+1:

Glad you found the resolution to your issues, would be interested to know if this does improve the performance of your instance if you get the chance to let us know :ok_hand:

Why do that in config_override.php when you can do that from the System Settings page.
You can find a dropdown for that: Minimum Dashlet Auto-Refresh Interval


@ blqt, you are right… it can be customized in the System Settings page. Thank you.

@blqt Double learning day apparently, appreciate letting us know!