Home page will not add new dashlets

This problem has recently occured, we do not know when, it always used to work.

When you add a new dashlet, nothing happens, If you keep clicking it it wll after a while say you had hit the maxium number of dashlets. But the home page does not change. I have cleared chache and tried a different computer and it is the same.

It seems to be adding the dashlet to the home page, but not displaying it. I can create new tabs on the home page, but not dashlet in the new tabs either.

as any one come across this before? Any suggestions. I have not changed any of the view defs for the users home page. There are no errors in apache2 or suitecrm logs

Any suggestions woud be great.

Is this happening just for one user?

If so, go in Admin / User management, select that user, and click in the action menu “Reset homepage”.

If that doesn’t solve it, you can try doing it from the database, find out the user’s id in “users” table.

Then go in user_preferences table, and find the row that has that user’s id AND the category is “Home”. Change that “Home” to “Home.DELETED” or something, just as a temporary way of deleting it.

Now login with that user. Your dashboard should be reset to default. You can un-do the database change if something broke. If it looks ok, delete the old database row.

1 Like

Sorry should have said. This is happening to all users.

It was first noticed as a user deleted a dashlet by mistake and we now can re-add it.

I have tried the reset user home page button, no change.

Hi, does any one have any suggestions?


Looking at the browser console, this error is produced when trying to add a dashlet.

TypeError: dashletEntire is null MySugar.js:68:497
    addDashlet http://crm/include/MySugar/javascript/MySugar.js?v=xdm_OhK9XoHnCxKjtEFMiw:68
    jQuery 5

Which version are you running, exactly?

Can you try different browsers to see if it makes a difference?

Version 7.10.7

Sugar Version 6.5.25 (Build 344)

We have tried a few browsers, computers and users all the same. We have a test installation and a live, All the devlopement happens on the test server and then is copied over to the love server once happy. This issue affects both servers.


I don’t know.what we could try. Maybe upgrade to the latest 7.10.x, there have been many versions since yours.

Other than that, only actually debugging this Javascript in the browser could give you a clue of what is wrong…

Hi, just an update on this. I have upgraded to 7.10.18 LTS and this has made no difference to the homepage situation.

I have also rebuilt all the java files in the rebuild section. still no joy.

Any ideas would be greatly appreachaited.

i wonder if you might have some add-on, or some customization, that is breaking this.

Do you know of any?

Another thing you can try is creating a brand new user, and seeing if you can add the dashlet on his homepage. Just as a test.

Thanks, New users have the same problem.

The site has been modified quite a bit, but all by custom entry points and the module builder.

I have modified the menu bar along the top, but removed that from the custom folder to see if that makes a difference and it doesn’t.

The strange thing is no error message anywhere. (well apache error log or suitcrm.log)


I would like to revisit this issue, Hopefully in the last 4 months someone else has came across this, I still have not had nay joy trying to add new dashlets, and no idea where to go next.

Any help would be great

Hi Pete

yes I am under the impression that this is solved in the latest version, but I couldn’t find a specific issue and solution, maybe I’m imagining things.

Have you tried this on the latest 7.11.10?

You’re the man !
Spent about 50 minutes searching for this solution; it happened for the Admin account, the other users had no issue with it;
How I broke it; wanted to add a chart dashlets, clicked several time and nothing was done; after that, the home page was not shown and an error saying that you should disable the AJAX for that module was received; of course the Ajax didn’t solved the issue.

But, your post did !

Oh, my version is 7.11.12 - just for anybody to know.