I’m not going to gaurantee that this is a fix for anyone besides me, but I read LOTS of threads spread out on the sugar forums about the same issue and could not locate an answer, let alone a quick fix. Please comment or make suggestions to this post if you have corrections. This is based on my limited understanding.
ISSUE:
Group e-mail fails to download in SugarCRM/SuiteCRM.
SYMPTOMS:
Test Settings of Inbound Email Settings indicates connection to server is okay.
Adding a Personal Email account with the Group Email settings works fine.
Sugar error log states:Wed Feb 5 17:41:02 2014 [4243][1][FATAL] SCHEDULERS: could not get an IMAP connection resource for ID [ 2d83a014-b9ae-72ae-f7ab-52f259fef0ae ]. Skipping mailbox [ BLAH BLAH ].
Accessing the cron.php job in the browser indicates that cron.php is CLI only.
CAUSE:
IMAP is not enabled for PHP-CLI despite being enabled for PHP. Cronjobs are based on PHP-CLI which may not have the same configuration as PHP.
SOLUTION:
PHP is running as CLI. This is different than regular PHP and requires that you have IMAP enabled in the php.ini for CLI. This php.ini is accessible under /etc/php5/cli. Add in the statement: extension = “imap.so”.
After I enabled IMAP for PHP-CLI I was able to successfully download group emails. Now I need to do the work to create a lead based on an incoming email to an account.
It sounds like you must be on a shared server with no real control over your individual configuration. You will not be able to manage PHP-CLI using those apps as far as I am aware. You can ask your host to enable the IMAP in PHP-CLI, but i’m not sure of any other option.
If I’m wrong and you are running your own linux server, please respond and let me know and we can try to walk you through.
Hello,
this error appear for me when many connection occur on the mailbox with the same IP.
The error is : Maximum number of connections from user+IP exceeded mail_max_userip_connections