Global search yields results only after a subsequent click on Basic Search

In Sugar CE 6.5.x, the global search box worked as expected. (You typed a search term and got results from all enabled modules.)

After upgrading to SuiteCRM 7.5.1, the result list is always empty. But if the user clicks the “Use Basic Search” link above the empty result list, the expected results appear.

The same behavior can be observed at the SuiteCRM demo. Is this controlled by a setting, or is it a bug?

The query string after clicking on “Use Basic Search” differs by including the parameter: search_fallback=1

Obviously, we cannot expect the users to click on a small link to see the results. What is the best solution?


The advanced search uses the AOD search which some users have had trouble with. In the admin panel under ‘AOD Settings’ you should be able to disable AOD which will make the basic search the only available global search.

Hope this helps,

1 Like

its interesting that it is still the same behaviour in the demo from suitecrm… no results!
so is this aod search still not working?!