Getting 403 Forbidden error when trying to save a Quote


I have just installed the CRM (version 7.11.8) via Softaculous. Everything was working fine until I have tried to create a quote and save it.

When I click on the save button, it throws me the error below.

You don’t have permission to access this resource.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

So far I am getting this error only with quotes.

I have tried to search if someone had the same issues here, but can’t seem to find any information.

Do you have any idea what might be causing it?

I am running it on PHP 7.2

Thank you.

I am guessing you have not set your file ownerships/permissions correctly and SuiteCRM can’t write to disk.

But in order to confirm this, do you see a few labels saying “undefined” in several screens? That is usually symptom number 1 of broken permissions.

If not, then I wonder if you have changed anything in Roles / Security Groups yet?

This is what happened:

  • I installed the CRM via Softaculous
  • Haven’t changed anything with regards to the Roles / Security Groups yet
  • The CRM directory is 755 (Was not asked to do anything with regards to the ownership/permissions during the setup )
  • I didn’t see undefined anywhere. The only problem I see is when I try to create a quote

Basically what happened is, installing it, importing some accounts, creating a product category, creating a product, and trying to create a quote.

Thanks for your help

What do you see in your logs when you save the Quote?

Only 1 error I see

[36831][-none-][FATAL] cron.php: running as userpro is not allowed in allowed_cron_users in config.php. Exiting.

Also, I found this one
[5482][1][FATAL] Chart class not found.

and in the error log
PHP Notice: Undefined property: aCase::$email1 in /storage/xxx/public_html/suite/include/generic/SugarWidgets/SugarWidgetSubPanelTopComposeEmailButton.php on line 104

And noticed that the cases are not created automatically

Do you have SSH access to this server?

Can you please get me the results of this command, given from the root of your SuiteCRM installation?

ls -al

In config.php you can add that “userpro” to an array key called allowed_cron_users, that should solve one of your errors.

It seems it was something related to the domain(Cpanel Account) I was running it. I have installed it to another account on the same hosting and it worked (Still had to add the user to the config.php - the CRON part.

Also, had to edit the CRON itself a bit to look like this
cd /storage/account/public_html/suite; /opt/cpanel/ea-php72/root/usr/bin/php -f cron.php > /dev/null 2>&1

Now I got another issue but will explain it in another post.