German Charset Issue - Umlaute Problem when searching

Hi all,
could find some topics about n this forum, but not on following fenomena on my installation Version 7.11.9

I can type, see and save all german special characters like ü ö ä in suitecrm screens and related database, but when I use these characters in the search fields they are not considered, and result is empty .
This happens on both installed language packs, english and german.

I immagine it is something in the php settings, but which ? Charset is set at “utf-8”.

You might also need to check your database, there is a property of the database that affects character encoding.

I think SuiteCRM is supposed to have utf8_general_ci encoding in the database.

Thank you prg,

but all tables in the database are already utf8_general_ci , so they have the special characters saved.
I assume something in the search routine of suitecrm that should be adjusted. any idea?

Which kind of Search are you using? Legacy, Advanced (Lucene) or Elastic?

Check in Admin / Search Settings

I don’t have the “search setting” ability in Admin., see foto

I am using image

Darn, that version has a nasty bug where the settings are gone for no good reason:

It’s fixed, but only in the next version which hasn’t come out yet.

Can you please just share a screenshot of your search results with a sample query? I think I can tell which type it is, from the look of that screen.


That should be Advanced Search which is based on the Lucene engine.

  1. If you click “Use Basic search”, is the recognition of the accents improved?

  2. In Admin / Schedulers, if you check the Lucene indexing job, does it say “last ran successfully” at a recent time? Or “never”?

pgr, you are top !!
Using basic search the results with the german characters are shown correctly.

I was sure from the beginning that it was a stupidity :slight_smile:

Thank you very much

Ok! When you have the Admin panel back, in the next version, you will be able to make Basic Search the default.