Fatal error 7.2x to 7.3 upgrade

I’m trying to update my suitecrm on a hosted godaddy server. I receive the following error after I commit.

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8892 bytes) in home/jasonpreti/public_html/clonecrm/modules/Administration/SugarSpriteBuilder.php on line 469

Any idea what I need to do to fix this?

You may need to increase your limits on your php.ini file.

If you are able to find your php.ini file please follow these steps listed on the SuiteCRM Upgrade Wiki Page:

  • Set post_max_size to at least 60MB
  • Set upload_max_filesize settings to at least 60MB
  • Set max_input_time to a large number
  • Set memory_limit to 256MB

You also need to restart your web server. Afterwards, try the upgrade process again.

Regards, John

Hi John,

But where is php.ini file is located??? I am upgrading suitecrm on godaddy hosting. I am also getting the same fatal error message.
Please help me to find this php.ini file or tell me how can we fix this error?
tell us the complete process.???

thanks in advance.

I found out that godaddy doesn’t let us modify php.ini. That was the last failure for godaddy. I’m changing hosting to dreamhost.com.

GoDaddy will actually let you choose a different version of PHP to use (not their system default) which you can edit the options and packages installed on.

Go to your GoDaddy CPanel > Choose Select PHP Version

Select any version higher than the default (i.e. 5.5 in my case) > Set as Current

You should then be presented with a number of options to choose from

Select Zip > Save

Click Switch to PHP Options > Set the options specified by John in earlier post > Save

That should get it done!