Error in email after upgrading to 7.9

I just upgraded yo 7.9 and the email in suitecrm has become extremly slow.
I´m cheking the logs and i can see this error

Wed May 31 11:45:23 2017 [21678][9b967fea-94dc-006d-d361-5718acf6d9bf][FATAL] Query Failed: SELECT count(*) c FROM emails JOIN emails_text on = emails_text.email_idWHERE emails.deleted=0 AND emails.type NOT IN (‘out’, ‘draft’)
AND emails.status NOT IN (‘sent’, ‘draft’) AND IN (SELECT eear.email_id FROM emails_email_addr_rel eearJOIN email_addr_bean_rel eabr ON eabr.email_address_id=eear.email_address_id AND eabr.bean_id = ‘9b967fea-94dc-006d-d361-5718acf6d9bf’ AND eabr.bean_module = ‘Users’ WHERE eear.deleted=0) AND emails.status = ‘unread’: MySQL error 1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘emails.deleted=0 AND emails.type NOT IN (‘out’, ‘draft’)
AND emails.’ at line 1

I have repaired and rebuild several times and not very clear what to do
I´m on ubutu 16.04 php-5.6 and mysql Ver 14.14 Distrib 5.7.18, for Linux (x86_64)

Any idea what should i do?
Best regards!

The Release Notes for 7.9 included a few additional steps that had to be taken, did you follow those instructions?

Hi, yes, i executed the sync inboud email accounts if you mean that.
i´m able to see the emails, but the load of the email screen is really slow and also i get the above errors.
Thanks for your reply!
Best regards!

  1. Please tell us what versions of OS, database, Web server and PHP are you using?

  2. When you do a Quick Repair and Rebuild, scroll down to the bottom to see if there is a message about Vardefs noot being in Sync with database (and perhaps a button to fix that - press it).

  3. See this thread for a similar problem with a solution:

1 . ubutu 16.04
mysql Ver 14.14 Distrib 5.7.18, for Linux (x86_64)

  1. It says the vardefs are in sync with the database
    3 .In this post talks about the vardefs in the route /custom/modules//Ext/Vardefs/ but there is no module for email

What i´m seeing that look strange to me the field uid in the studio
i cannot upload any image righ now i dont know why, but the field is created in the studio but all the field are empty, even the system name

Thanks again!
Best regards!

You can upload an image in external sites like pasteboard or similar. It might be helpful…

I too have same issue after upgrading from 7.8.3 to 7.9.0 I have identical error in logs and issues loading emails, in fact sometimes they load and sometimes the screen just become unresponsive. Tried running with PHP 5.6 and 7.1 with same result :frowning:

Why do you say the “uid” field looks strange? Can you show it in the list view alongside the other fields (like in that post)?

Because everything inside is empty
This is how it looks in the list view

And this is how other field looks

You can see the fiel Etiqueta del sistema is populated automatically, but in the uid field is empty.

Is the only strange thing i can see.
Thanks and Best Regards!

Yeah but I’m not sure that’s a problem because “uid” is an internal field that never gets displayed to users, so it doesn’t need a label…

I can’t think of any other solutions at the moment…

Thanks for your helps anyway,
Also interesting blog :slight_smile:
Best regards!

To all the people out there,
Any ideas?

I just checked in another system, going into Studio, and the Emails module also has that “uid” field, looks the same as yours. So I don’t think that’s a good clue to follow.

We need to stick to your original error message, try to find out where that’s coming from.

I see a missing space in there, before the WHERE:

JOIN emails_text on = emails_text.email_idWHERE emails.deleted=0

is it really like that in the original message, or did you just lose the space when copy-pasting into the forums?

1 Like

Ok, never mind, it IS a bug, missing a few spaces in the query

I see it’s already fixed in Github so we just need to wait for it to be merged and released.

Meanwhile, you can go to that file and change it manually, if you want. It needs a space before WHERE and another one before one of the JOINs.

1 Like

Thank you very much for your help!