Error Code when Importing Data

I am importing opportunities and keep getting the following error code. I have deleted line 288 and 305 (as well as the lines around them) and still keep getting the error codes.

NOTICE: [8] Undefined property: Account::$SecurityGroups on line 288 in file C:\Bitnami\suitecrm-7.10.7-0\apps\suitecrm\htdocs\data\Relationships\M2MRelationship.php
NOTICE: [8] Undefined property: Account::$SecurityGroups on line 305 in file C:\Bitnami\suitecrm-7.10.7-0\apps\suitecrm\htdocs\data\Relationships\M2MRelationship.php

Any ideas I am repairing the database ATM.


Found the error code lines in the PHP…

Anyone know what I need to change to resolve the error?

    //Need to hijack this as security groups will not contain a link on the module side
    //due to the way the module works. Plus it would remove the relative ease of adding custom module support

      if(get_class($lhs) == 'SecurityGroup' || get_class($rhs) == 'SecurityGroup') {
      	$dataToRemove = array(
      		$this->def['join_key_lhs'] => $lhs->id,
      		$this->def['join_key_rhs'] => $rhs->id
            if (empty($_SESSION['disable_workflow']) || $_SESSION['disable_workflow'] != "Yes")
                if (get_class($lhs) != 'SecurityGroup' && $lhs->$lhsLinkName instanceof Link2)
                    $this->callBeforeDelete($lhs, $rhs, $lhsLinkName);
                if (get_class($rhs) != 'SecurityGroup' && $rhs->$rhsLinkName instanceof Link2)
                    $this->callBeforeDelete($rhs, $lhs, $rhsLinkName);
      	if (empty($_SESSION['disable_workflow']) || $_SESSION['disable_workflow'] != "Yes")
      		if (get_class($lhs) != 'SecurityGroup' && $lhs->$lhsLinkName instanceof Link2)
      			$this->callAfterDelete($lhs, $rhs, $lhsLinkName);
      		if (get_class($rhs) != 'SecurityGroup' && $rhs->$rhsLinkName instanceof Link2)
      			$this->callAfterDelete($rhs, $lhs, $rhsLinkName);
      } else {

Solved this by deleting the security groups I had made in admin… not sure what was happening, but seemed to do the trick.

If the notices were coming up on screen, you should go in your php.ini and disable display_errors

You should track the errors in your logs only.

Normally, NOTICES are safe to ignore. I assume that apart from the messages, you were also getting a broken import? Or was it just the messages bothering you?


Was just the messages, removed the security groups I had created and that resolved it.

I am having an issue now with importing the files.

I imported about 6000 opportunities. Only 2000 have all the details, the rest just the account and opportunity name. They do not update, even with the correct Suite ID Set.

I delete them, re upload. Everytime these 4,000 remain stubbornly blank. Any ideas?? It will take me 2 months to manually enter all the data.

I downloaded all the opportunities and transferred the ID’s to the correct ones and re-uploading the documents in the import wizard,
selecting “Create new records and update existing records”

The field mapping looks fine, (even has the data)

Select - check for duplicates (though I have tired it without)

Upload goes fine, says updated records and check, they are still minus all data!



Keep an eye on your logs

php_errors.log (or whatever your web server log is called)

There could be relevant messages there.

I don’t understand your import:

  • are you importing Opps and relationships to other tables (accounts)?

  • what do you mean about the correct ids?

Solved it.

I had limited the characters on one of the fields to 5 and the data I was importing on the 4000 had 7 characters in that field. Once I increased the size limit in Studio, it solved the issue.

actually that’s not solved. you just did a workaround by fixing data to be imported.

current error message (7.11.13)
NOTICE: [8] Undefined property: Account::$SecurityGroups on line 288 in file /var/www/html/data/Relationships/M2MRelationship.php NOTICE: [8] Undefined property: Account::$SecurityGroups on line 302 in file /var/www/html/data/Relationships/M2MRelationship.php

Warning does NOT mean its not critical as your data being corrupted. Some data may imported and you have no choice of roll back, as regular.

How to reproduce:
If you import person and salutatory does not exist in the lookup you get an error.

How it should work:
If you import company’s for example and industry contains invalid values you get a warning generated by suitecrm with the rollback option as well.