Enable SSL?

Our new suiteondemand hosted implementation is not using SSL. I had assumed this would be enabled out of the box in a hosted app, but it doesn’t appear to be. Simply changing the protocol to be HTTPS doesn’t work - it results in a 404. I don’t see anything under Admin for configurating this. How do we enable SSL?

I don’t think enabling SSL is just a switch you can turn in the Admin screen, because it involves purchasing and configuring a certificate.

I suggest you contact the SuiteOnDemand support, they should be able to tell you your options.

I came across this and it’s like WTF? What world or century are you living in?
Thankfully there is Let’s Encrypt which provide valid SSL certificates so anyone can freely encrypt the connection to their website.

I have 100 apps using SSL in such fashion. Installing SSL is fairly simple and easy and its configuration goes into apache or nginx.

I am shocked with the lack of quality of this response.

You’re shocked at me telling a paying customer to contact the exclusive support he payed for?

I mentioned Let’s Encrypt on plenty of threads here of people asking similar questions, who weren’t using Suite on Demand.


So take it easy, man…