EmailAddress in Module onlyText not Active Email for clicking.

I have Module XXX and and a Excel-File with fields Email who are “Active” (showing in blue, upon clicking I get Email Popup screen from: and to: etc.

I saved that file as CSV file and imported that CSV file into the XXX module. But there i see only the emailaddress as “Text”(not in blue/active)

I did map the CSV Emailaddress with EmailAddress (textfield) in the Module, and then imported it.

In the CSV files to be imported the Email is not “active” anymore but in the Excel sheet it WAS !!!

How to do this ?. I need an active email in that Module.

Working on Windows 10/Bitnami/Suitecrm 7.6.4


I think you’re talking about something called “linkification”, which is detecting that some text is a link, or an email address, and making it clickable in HTML.

Excel does linkification for you - text files like CSV usually don’t have that option (though it really depends on your Editor).

To get linkification of custom fields in SuiteCRM, you might have to add some simple custom code.

A way to work around this is to use a browser extension to take care of linkification for you, there are a few out there for Firefox and Chrome, at least.

I googled for this linkification in Chrome, but all say it destroys the Search in Google, so that is NOT the solution. Linkify only for Mobile Phones.
So what is left ?.. some code ? if so, show me that code to convert an Email Address field (now sill plain text) into an Active, Clickable field for
gettting it active.
Thanks, William.