Email Settings BUG or misconfiguration?

I am seeing a malfunctioning in my SuiteCRM installation, but it is so strange that I’m more prone to think it’s due to some misconfiguration rather than a real bug.

Here’s what’s happening

FIRST STEP - CONFIGURE Email Settings via Admin menu

  • SuiteCRM version 7.9.7
  • Admin -> Email Settings
  • Choose your Email provider -> “Other” and then fill all the requested fields
  • Use SMTP Authentication: -> TRUE
  • Username and password as requested by our mailserver
  • Allow users to use this account for outgoing email: -> TRUE

SEND TEST EMAIL -> OK!

Users can now use the default outgoing mail server for sending emails to prospects, leads etc.

SECOND STEP - Modify a User Profile

  • Login as one normal user
  • Edit profile
  • In Email Settings section click SETTINGS
  • In Settings window, click Mail accounts tab
  • In Mail Accounts edit the user’s mail account (click the pencil icon under Edit column)
  • In the Mail Account Properties window check all the parameters, then check send test email -> OK
  • Click DONE

After this last click, users cannot send emails anymore. After checking around, I found that SMTP username+password in System Email Settings are overwritten by the username+password of the CRM user who modified his profile in step 2.

I don’t understand, CRM username+password has nothing to do with systemwide SMTP AUTH username+password.

Any suggestion? Thanks!

This is a known bug and would be fixed in coming releases.
You can follow following threads to apply the fixes proposed.

https://github.com/salesagility/SuiteCRM/issues/3841
https://github.com/salesagility/SuiteCRM/issues/4057

Will do, thanks.

As my issue is slightly different, I will follow the suggestion and add these steps to #4057.