Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Email Campaign Issues

Hello, I have a problem with sending Email Campaigns mass email. I have set the mailing limit to 1000 because any bigger value is not working and then it’s sending only 100 mails. However the biggest problem here is the performance of mail sending which is very slow and when the mass sending is executed the SuiteCRM crashes with Internal Server output - usually for the user who executed the mail sending but sometimes for everyone. Is there any way to improve the performance of the campaign mails and the limit amount? My SMTP server does not have any mail limits per hour.

@JKB16
please check if your “Email campaign Settings” increase your limit


And please cross-check your SMTP setting:- How to Bypass 2 step verification for Third-Party Apps using App Password - YouTube

I like to check the PHP INI settings for this domain:
max_execution_time and memory_limit.

Besides checking the SuiteCRM Email campaign settings, I also make sure the number of emails per hour is not greater than the server maximum amount per hour.

I also double check on the server the number of emails a domain may send per day.

if I set more than 1000 there, it sends only 100 emails - for me, it seems like 1000 emails are the limit.

Could you please tell me in which file I can change the max_execution_time and memory_limit?

That campaign emails limit is just a batch size. After one batch, it sends the next one after a certain time. But I’ve never heard of any 1000 limit.

In Admin / Diagnostics download phpinfo. There you will find your effective values for those settings, and the path of your php.ini which is the file you need to change.

Okay, thank you for your explanation. Is there anything that I can do with the web service jams when emails are executed - sometimes it is also affecting other users and they can’t reach the SuiteCRM site

I would start by looking at your problems as performance problems. Try to investigate that first.

Apart from the php.ini settings mentioned above, also try going into phpMyAdmin and running the first query in this post:

SuiteCRM sometimes gets into trouble with overgrown tables, if you don’t do enough database maintenance.

Here are my limits:


Are these values correct or too small and where can I change them?

I believe that my tables are not too big since this CRM system is quite newly created:
image

What does your error report say? Anything? Just throwing it out there it may NOT be a timeout issue. It may just be that when sending 100 all the records are good, but when you send 1000, maybe email address #105 is corrupted and crashing the mailing. Just double check your error log to make sure a specific record isn’t the problem.

In terms of PHP memory make sure both your main directory xxx.com and xxx.com/suitecrm both have sufficient memory in the PHP ini (I prefer 512M).