Email attachments and images not accessable when receiving email

Hi Guys,

Just upgraded from 7.8.4 to 7.11.18.

When someone sends an email to the new install, I can’t access an attachment (something as simple as a text file).

If I forward the email, then the attachment shows up and is accessible. So it is there, I just can’t access it when reading the email.

I also don’t see an image placed in the email by the sender. For example, they used the Windows snipping tool to put the image in the email.

Any ideas what may be going on?

Screen shot when received

Here is the screen shot when I forward, now attachment can be seen


Hey there,

Are you still having issues with this?

I believe that the Email functionality behaves quite differently now, as of 7.9

The CRM now grabs the minimal amount of information from the Mail server, for the initial viewing of the Email

You should be able to view the attachment, and all other info related to the Email record, by clicking “Import” on the Actions menu

You can read on this more here:

Hi John,

Yes, I am still having this issue. Thank you for getting back. This is version 7.11.18 that I am having this problem.

I just tried your suggestion, but don’t see an IMPORT option. We get voicemail in our Inbox. Sometimes we just want to listen quickly, w/o hassle. Same with quite a few other attachments.

Just these:


Just tried another user account, and it does indeed have the IMPORT. This one only has the following below. But I still do not see the attachment. And now after playing with it, the IMPORT goes away if you read the email, and then come back to it later. Then you see the list above.


Looks like there was an issue with this in earlier version, but after reviewing the code in 7.11.18, it was changed as suggested in these link. But still not working for me. I have ensured Permissions on everything is Enabled and set to ALL.


Thank you for the clarifications!


As far as I’m aware, the “Import” action, as well as the shorter list of actions:
Should only appear if the Email has not yet been imported into the CRM
(This is the stage in which the Attachments are normally not available to use/see in Notes/Documents modules)

Only after Importing, should you see the longer set of options:
(As well as attachments then being available)

You can tell if an Email has been imported by the Purple Checkmark:

So, the Actions available shouldn’t change simply from:
Clicking onto the Record -> Navigating away -> Clicking onto the record again

However, it seems to be behaving differently on your instance, is that right?

Do you recall what Upgrade path you have taken from 7.8.4->7.11.18?
I’d like to try to replicate it.

Also, after upgrading, have you run either:

  • Quick Repair and Rebuild
  • Rebuild JS Grouping Files
    In Admin->Repair ?

I would recommend running these, as it can rule out any odd caching issues from the Upgrade

It may also be worth ensuring the File/Folder permissions are up-to-date, especially on any new files from the upgrades.

We usually recommend:

sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php
sudo chown -R www-data:www-data .

(Replacing www-data with your web server user)

I have done the rebuilds (more times than I can remember !)

Here is my upgrade path

(if fails go to C:\wamp64\www\SuiteCRM\cache\upgrades\temp and delete file)
7.8.4 to 7.8.10
7.8.10 to 7.8.29
ran the batch file to create theme cach directorys - see documents
7.8.x to 7.9.16
7.9.16 to 7.10.6
7.10.x to 7.11.18

BTW - This is not the first time I’ve had this problem. Ive done this upgrade several times, and different versions of just about everything and have always ran into this problem.

I also tried this path, which broke in 7.9.17, but then I continued as indicated above to see if it would “self correct”. Have tried several upgrade paths, but always have ended up with this problem.

7.8.4 -> 7.8.11 -> 7.8.19->7.8.27->7.8.31 (email good to this point)

From 7.8.31 jumped to 7.9.17 and email is broken

Well, if anyone is still out there, still having this issue. Tried a brand new, fresh install of SuiteCRM 8.2.2 Still do not have ability to view attachments when viewing an email. Can see they are there, but can’t access the attachment. I can perform an import, and then the attachment is available. But not until then. Is this the expected behavior?

This is what it looks like

And then when I open the email


As you can see, there is no link to click on to view the attachment. Now, if I select Import, then it looks like this. Seems odd that you need to import in order to gain access to the attachment? Is this expected behavior? I don’t even have to select where it gets imported, just import to nothing???

Once import has been peformed, all of these options show up below the email, and then the attachment can be viewed