Document Upload Issue.

Good day all. First, let me congratulate everyone on a job well done.

Please bear with me if I post this is the wrong forum.
Also, I always try to give as much information as possible, sometimes to the point of being annoying.
My objective is to “Hit it once and not waste peoples valuable time”.

So here we go.

Installed vSuiteCRM-7.8.0 without issue. We have met all the install requirements (mysql, php, web server, extensions, permissions etc).

Scenario 1:
Windows 2008R2 Server, Apache 2.4 (fastcgi), php5.6, mysql community-

Scenario 2:
Windows 2008R2 Server, IIS7.5 (fastcgi), php5.6, mysql community-

Scenario 3:
Centos 6.6 Server, Apache 2.4 (fastcgi), php5.6, mysql 5.7.9

No xamp, wamp etc - all manual installs and have been stable as above for over a year. Other CRMs are okay, ModX, and a variety of other systems all work just fine.

These machines are in our dev/test lab and are rock solid in terms of updates/patches and stability of features.

Before we do anything with these systems, they are in a basic raw state and we image them. Play with want we need to play with, get things working, then revert them back to the original “clean Image”. So we are are quite confident that we have solid and clean test systems.

In all cases, we can upload a document without incident. In these test we used: pdf,txt,png,jpeg.

In all cases, the file gets uploaded to the suitecrm/upload folder (with of course the “nifty name”).

In all cases, there is no extension on the file displayed in the uploads folder - makes sense, security related.

In all cases, the correct date is displayed in the upload folder and we can see the file in the appropriate OS console (or gui).

Now; when we click on the link in say SuiteCRM History (or edit the note for ex), we get nothing displayed at all.

Just a blank screen. In IE, we get a 500 error indicating that there is something wrong with the server (duh - thanks MS…).

I downloaded one of the files I uploaded 20 minutes ago, added a png extension and it opened fine in PS, Pic viewers etc.

So, we 99.9999% confident that permissions are in order (the file uploaded fine), the actual file is fine (ftp’d it down).

We have tried viewing just the images in 5 different browsers (FF, Chrome, Opera (my mac), Safari and yes IE (10,11).

We tried a previous version (SuiteCRM-7.7.9) as well with the same results.

Plain vanilla install with sample data, no branding or changing of any system settings.

We really need some pointers on this one, we must be missing an extension or a setting is out of whack.

Thanks for letting me ramble…

Courtesy Post…

check this post

best regards

Is php_fileinfo.dll activated in your phpi.ini?

Thanks mikebeck and Simeon. It was “php_fileinfo.dll” not being activated.

What I meant by “Courtesy Post”, was that we resolved the issue and I wanted to let the forum know so as not to waste anyone’s time.

Thanks for the intel guys, it’s appreciated.