👋🏾 Looking to join our SuiteCRM Community Working Group? 💌 Open invitation throughout January. Check out all the details here 👈

Default Language (and/or disable English)

Hi

I have set up Suite for a German company. With the German language files for Sugar and a little addition here and there I am quite happy with the result.

What I am somewhat missing is to set German up as the default language. If I have multiple languages enabled (German and English), English is always selected when I first load the login page. Any order in the admin languages menu has no effect.

Also, I tried to disable English altogether as my users will always use the Suite in German. If I do and have German as the only enabled language, I will not be presented with the language selection dropdown (as expected), but the Suite will be fully in English.

This, obviously, is not the most pressing of issues. But I’d be happy if it could find some kind of consideration in future releases.

Best
Jan

Did you edit your locale in Admin->Locale area?
Then reset user preferences?
You can also edit the config.php file
Back it up first so you can recover it. If you mess it up.

array (
‘en_us’ => ‘US English’,
‘fr_fr’ => ‘French’,
‘ge_ge’ => ‘German’,
‘es_es’ => ‘Spanish’,
)

To

array (
‘ge_ge’ => ‘German’,
‘en_us’ => ‘US English’,
‘fr_fr’ => ‘French’,
‘es_es’ => ‘Spanish’,
)

Effectively changing the order languages will appear on the login page.

You can also manually set your default language in the config.php file to ge_ge

find

‘default_language’ => ‘en_us’,

and edit it directly to

‘default_language’ => ‘ge_ge’,

Chad

Hi crobinson,

thanks for the pointer. I could, in fact, solve the issue by manipulating the config file. However, changing the array didn’t do anything. Only changing the default language did the trick.

Thanks!

Hi guys,

If you want to make safe changes to your CRM, make changes to the config using config_override instead of the original config file.

Thanks,

Will.