Date Filters or start date filters are not working in reports if we add as a parameters

When i create the report and add date filters and tick the parameters in condition and select the particular dates and save the report it does show the reports but when i change the dates and update the report it show blank result and also selected dates from date fields disappear. Im using suitecrm version 7.10.9 and I have also tested this in latest version 7.11.8 has the same issue.

Can someone help on this.

I think I remember seeing on GitHub and issue that happened when TWO dates are used (such as when specifying an interval of dates), is this your case?

Hi pgr,

I have tried with this github link still no success.

Let me know how to fix this issue.


Are you using the same date field twice?

We have a bug for that in Dashlets, and another in Workflow. You might have one in Reports, and I wonder if this isn’t all the same thing…


Yes i have added start datetime filter twice in condition, when we create the report and save first time it shows the expected result and when change the date filters in parameters it doesn’t show any result and data filters are blank. See below two images

Can you please add your “steps to reproduce” and your screenshots here?

I do think it’s probably all the same bug.

I am creating simply report for leads module and adding the date filter twice in condition see attached screen shot.

When i save the report it show the expected results
When i change the date filters in parameters and then update the report it gives blank and even date filters get blank

Sorry I probably wasn’t clear, I meant to ask you to post the screenshots on that Github issue since that is what the developers will be looking at.

Thanks and sorry for the trouble.