Dashboard - Not able to advance ; retrieve_dash_page.php

Good Day

A user reported, is reproducible, an issue that happens in dashlets that have more rows than
can be displayed.

Specifically, if the user selects to advance to the next set there is no response(update, no next set…)

There is a Warning that comes up in the php error logs :

PHP Notice: Undefined index: in retrieve_dash_page.php

Also see some javascript error in the console:

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check http://xhr.spec.whatwg.org/.

I have discovered that If I Edit and Save (no other action beyond opening the Options and doing a Save). the advance does work.

I Hope this is enough details to understand the issue.

Let me know IF I need to provide more information OR if there is a fix AND the means to apply.

Thanks in advance for your time


Anybody have thoughts/feedback on this? Is there more information I can provide?


If you access the dashboard by clicking the “SuiteCRM” hyperlink on the top-left of the screen, it will take you to a Dashboard that doesn’t utilize AJAX, so you may get some Dashlet Issues.
If you navigate to the Dashboard through the other “Home” buttons, like the one I have attached, does the issue occur?

I am having the same issue and you are right, It only happen when you access the dashboard through the top-right hyperlink. Accessing it from the other Home buttons works fine. Any thoughts or a fix ?
Thank you

Found this fix and it’s working fine now.

Thank you

Hi John,

Same situation --> will not forward.

Note: If I follow steps as noted (edit , save ) and retry it worked

Thoughts? The version is 7.3.1

One additional note - The I have a tab for testing with just one dashlet and it has the issue until
the Edit->Save steps. I was trying to isolate the behavior. There should be no difference from
the ‘Suite Dashboard’ to a ‘tab’ other than the tab I set up with just a single dashlet, correct?

I have run the Admin-> Repair . That did not have a noticeable impact/change

I also tested in the other provided theme in case it was UI issues.

Let me know if there are other details I can provide



How are you accessing page with “Suite Dashboard”?
As said previously, if you access it through the “SuiteCRM” link on the Top-left of the page, it causes Dashlet issues due to it not loading an AJAX Supported Page.

If you access it through the way shown in the screenshot provided, do you still get issues? It should load an AJAX Supported page.
Editing > Saving also loads an AJAX supported page, so there should be no issues.

manasa7416362340 also provided a temporary fix to the issue here: https://suitecrm.com/forum/developer-help/6455-dashlet-data-is-not-showing-properly#23131
Have you tried this?