CSRF Errors and custom fields not showing up

Dear Community!
I have just set up SuiteCRM 8.0.3 according to the manual on my webspace.
I have used the subdomain crm. mydomain. com, which points to mydomain.com/crmfolder/public. I have noticed when using the crm, that is being shown in the address bar.
I’ve set all the chmod and chown values according to the manual.
Now any setting in the admin Panel gives back the CSRF error, following the direction do add crm.mydomain .com or mydomain.com to the http referer list has not resulted in any changes.
the only thing that helps are those very long very specific exemptions that are suggested, which of course make the installation more unsafe.

In addition, now when I create custom fields for contacts, they show up on importing CSV files and I can map them accordingly, however when I view the contact or try to sort contacts by this, custom fields are not displayed.

I suspect both these errors might be connected, however I am not an expert.

Additional Info:
the custom fields show up in phpmyadmin in fields_meta_data
my site_url in config.php is crm. mydomain. com
host_name is 127.0 .0.1 , but changing this to mydomain .com has not worked
I have tried repair and rebuild multiple times.
My admin page did start to work a little more after the following had been automatically inserted (dont know why):

$sugar_config['http_referer']['actions'][0] = 'index';
$sugar_config['http_referer']['actions'][1] = 'ListView';
$sugar_config['http_referer']['actions'][2] = 'DetailView';
$sugar_config['http_referer']['actions'][3] = 'EditView';
$sugar_config['http_referer']['actions'][4] = 'oauth';
$sugar_config['http_referer']['actions'][5] = 'authorize';
$sugar_config['http_referer']['actions'][6] = 'Authenticate';
$sugar_config['http_referer']['actions'][7] = 'Login';
$sugar_config['http_referer']['actions'][8] = 'SupportPortal';
$sugar_config['http_referer']['actions'][9] = 'Upgrade';
$sugar_config['http_referer']['actions'][10] = 'index';
$sugar_config['http_referer']['actions'][11] = 'ListView';
$sugar_config['http_referer']['actions'][12] = 'DetailView';
$sugar_config['http_referer']['actions'][13] = 'EditView';
$sugar_config['http_referer']['actions'][14] = 'oauth';
$sugar_config['http_referer']['actions'][15] = 'authorize';
$sugar_config['http_referer']['actions'][16] = 'Authenticate';
$sugar_config['http_referer']['actions'][17] = 'Login';
$sugar_config['http_referer']['actions'][18] = 'SupportPortal';
$sugar_config['http_referer']['actions'][19] = 'repair';
$sugar_config['http_referer']['actions'][20] = 'Locale';

other than that there’s $sugar_config[‘http_referer’][‘list’][0] = ‘mydomain .com’; in there.
this is regarding both the config_override in /legacy and /public.

I would much appreciate any help! thanks in advance!

Replying to myself here, as I cant seem to edit; Another issue is I can only log in with microsoft edge. Chrome and Opera say login credentials are incorrect.