CRM v7.14.1 Composer issue

New installation of V7.14.1 On Ubuntu 20 LTS and ran Composer Update --no-dev.

I have a custom file with exec command for cron via php. This is giving me following error.

Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.4.0”. You are running 7.2.34-nmm8. in /www/htdocs/w3236551/crm/vendor/composer/platform_check.php on line 24

Is this a platform error or composer error ? PHP CLI version is PHP 8.1.22 (cli) (built: Aug 23 2023 10:55:13) (NTS)

That’s strange. There is some discrepancy between how you’re checking your PHP CLI version, and how Composer is doing the same thing. You’ll have to figure out what is it, about the way you launch composer, that sends it to PHP 7.2… but I’m not seeing any obvious possibilities from here…

i backed up the vendor folder and re-installed composer without platform requirements. It added new library filed and there were some libraries that had code issues, fixing those gave me clean results and issue is resolved.

1 Like