Create User or Employee button/anchor missing from user interface

I am new to SutieCRM and so far I have found it to be very good. I am in the process of evaluating CRMs and my shortlist is basically down to SuiteCRM or vTIger (both born from Sugar!)

I have installed without any apparent issues and am up and running. There does however appear to be a problem with being able to create new users and/or employees.

I have searched through forums and Google etc and have tried the various solutions offered, Repair, rebuild, check permissions etc and none seem to have had any effect.

Digging in a bit deeper, I did find reference the correct URL for creating users …/index.php&module=user&action=editview and pasted this into the address bar and the page and ability to create a user worked.

Now, having been armed with the correct URL, I searched through the source code of the HTML and discovered reference to this URL close to the H2 title - USER. However it is hidden by the CSS selector with a display:none. Changing that, through the browser tools, to display: inline or block enabled the anchor to appear (plus a couple of other anchors).

Also, I would expect this anchor to appear in the left column, in the actionMenuSidebar div above the Recently VIewed items. Nothing is contained within this div.

Therefore a couple of questions:

1: Should the anchor alongside the H2 be visible? Why is it display:none?
2: Should there be an entry in the sidebar, like for other modules?
3: Am I missing other sidebar entries, in other modules, without me actually realising?

Thanks in advance for any pointers to resolving these issues.

I assume you’re using 7.10.3. If so, this is a known issue, it’s fixed and we’re anticipating the 7.10.4 release to early next week to fix this Issue. Sorry.

1 Like

Thank you. Yes I am. I shall await the patch next week.

If you’re in a hurry I think these are the changes you need to apply.

Of course, backup any files before you change them manually.

Use the following link to fix your problem, after using it the problem disappear for good: