ContInue equivalent to break 500 error after install


I’ve done everything possible to fix this problem. Permissions aren’t the issue. I’m getting the error:

I changed the line to “continue 2;” and based on Google search suggestions, also changed it just to “break;”. Nothing has worked.

This is my first time installing SuiteCRM. The installation goes great and finishes, I hit the “Next” button and get a 500 Error. The above is what the error log shows.

Could anybody please advise? I really really want to use SuiteCRM, but I can’t get it set up to try!


What is your SuiteCRM version? And PHP?

I don’t think your problem is that “continue 2” thing, I think it’s something else…

Can you explain better where you are when it breaks? And does it hang for minutes, then crash, or does it crash immediately?

It happens immediately after install, specifically where it lists out installed modules and the time it took to install (Approx 30 sec each time). As soon as I hit the “Next” button, I immediately receive the 500 Internal Server Error.

PHP Version: 7.3.1
SuiteCRM Version(s): 7.11.9 & 7.11.10

Side note: I also tried every combination of turning off error display and logging, including adding & ~E_WARNING - in php. ini. After the initial Warning in the error log, no other events become logged when going to install.php

If your “About” main menu option shows the new version, then don’t worry about it. It’s a known issue (I’m working on it right now) that breaks the final report at the end of the upgrade, but doesn’t cause any other problems that I know of.

The weird thing is it happens with both the latest version and the last version. And just to be clear, it’s on a fresh install.

The other thing I just tried yesterday was to install my host’s version of SugarCRM CE and then I was going to upgrade… I recieved the same error. They said their engineers have had a few reports of that happening and are working on a solution.

I will wait patiently for a fix, I appreciate you helping!! I want to use SuiteCRM so bad. I’ve implemented other CRMs very in depth, and all my research for my current needs points me to SuiteCRM.

Thanks again!

I don’t recommend installing SugarCRM CE and then upgrading, that’s a much more complex process.

I noticed something you wrote above - it fails after 30 seconds. Have you checked the resource limits in your php.ini?

max_execution_time (I’m betting this is where you have 30 seconds)

Increase any of these if necessary, then restart web server.

Make sure you edit the correct php.ini, for apache, not for CLI.

That page that is displaying “30 seconds” says installation has completed and lists all the modules installed. It doesn’t redirect to a 505 Error automatically by itself, it happens when I click “Next” after install has completed. It has gone up to 34 and 36 seconds total install time shown on the final install report. Then I click Next, get the 500 Error and the Error Log shows the error in my original post

Here are my setting from the beginning:

max_execution_time = 120
memory_limit: 512mb

The other two options aren’t in my php.ini

You can make sure that you are using correct php.ini by creating phpinfo() file that prints out the details about your PHP settings along with the PATH of php.ini file that is being used. Can you share the Screenshot on the Page on which You are getting error?
It would also be good if you can check the Console(press F12 to open the panel) of the Browser for any JS/Network errors too.

It is 100% the correct PHP.ini file.

I cannot screenshot anything… The error in the log I’m getting is in my first post, but my log isn’t logging any new errors.

I’m still getting the 500 Internal Server error (without any other information text) when I click Next after install or if I go to host/install.php after installation completes.

If the installation is complete, you should be directed to the index.php not the install.php page.
can you directly access the index.php page by hitting the URL?

No, that gives me a 500 Internal error, and the install.php does as well. I don’t get any other error log messages, just the original one from my post in this thread.

I just installed 7.11.10 again. My host updated to PHP 7.3.2 - After the installation completes, it doesn’t move me to index.php, it stays on install.php but with a 500 Internal Server error.

Upddate: I looked at the new install log and this is exactly where it’s been hanging every time. Even though the installation page shows completed with a ton of modules loaded, it shows success, there is nothing in the log after this. Any ideas?

2019-11-13 23:07:52…saveConfig
2019-11-13 23:07:52…new Currency
2019-11-13 23:07:52…retrieve
2019-11-13 23:07:52…DBG: save currency
2019-11-13 23:07:52…Save user settings…
2019-11-13 23:07:52…DBG: SugarThemeRegistry::getDefault

make the permissions on theme, cache, custom folders to be 777 recursively. Also check the HTACCESS file for the correct root path.

I’m having the same problem when attempting to upgrade, on the final step I receive the 500 error.

Tried installing 7.11.10 fresh and it wont even launch the installer, same 500 error.

All other php.ini settings are fine, did not have problems installing fresh 7.11.9, not sure what gives.

Any suggestions?

Try clearing your


directory and starting again.

Thanks for the reply.

This is now a clean install of 7.11.10, did not find an “Upgrades/temp” folder, I receive the 500 error right of the bat.

Any other suggestions?


Have a look at this issue and the associated PR

I can confirm I have the same problem with a clean install of 7.11.10

Installer works without any problems.
“Checking environment” shows OK on all points.
Database connects, no probs (fresh db).

Installer runs for about a minute, then confirms success:
“The setup of SuiteCRM 7.11.10 is now complete!”

I hit “next” and immediately get a #500 error when getting redirected to install.php.

Accessing index.php does not change it. Nor do any changes to the php.ini (which should be okay, anyway).

Deleting cache/upgrades/temp doesn’t help. As I said, clean new install, there no “upgrades” subfolder in /cache.

My error.log only shows:
AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

I guess this points towards a problem with the .htaccess file. The only detail that caught my attention there - I added

RewriteBase /

towards the end of the file, right after

RewriteEngine On

, but that didn’t help.

Kinda lost here, can’t seem to get it running. And the PR doesn’t really help me, either.