Cleanup of SuiteCRM


I’m having more and more trouble upgrading SuiteCRM after each upgrade. It somehow looks that the upgrade-process just get’s slower and slower, and now finally i could not manage do do an upgrade without moving away everything from upload/upgrades/patch/.

The upgrade-wizard ended also in a timeout, but after checking the About-page, it shows that i am now running the latest 7.11.10-version.

Somehow it looks to me that every upgrade makes the next upgrade more complicated, and now it looks that istart to hit the wall… The upload/upgrades/patch/ contains 24 patch-dirs, and it’s total size is 1,3GB.

I wonder if cleaning up everything by ding a “clean install”, but preserving the database-info + uploaded files would work…

Any hints or ideas?

You are right, the upgrader had bugs which we fixed for the next version.

My recommendation is to delete cache/upgrades/temp and start over. If you still run into timeouts, then wait ofor the next version as it will contain the fixed upgrader.

See this and the corresponding PR’s

Please try this:


$skipDirs = array(
$sugar_config [‘upload_dir’],

This will prevent timeouts in the initial step (checking permissions), but not in the others. But it’s worth a try since for some people it might be enough to get the upgrade to work.

I tried to add cache + upload to the array, but it looks that i managed now to break my SuiteCRM somehow, and now uploading the zip-file somehow fails. The upload itself works, but it won’t show up as an uploaded package…

I assume that if if recover to a backup of my install-dir, and but leave the database as it is, the upgrade-process will manage the database evein if it would be the db after a previous upgrade?

Have you done this :point_up:?

You might also want to clear `upload/upgrades/patch/´

And make sure you didn’t insert any syntax errors when playing with skipdirs array…

I had not moved away cache/upgrades/temp because i thought that this has to be kept. Now when i did that, and deleted cache/upgrades/temp, i’m hit with the blank wizard-page… :frowning:

The upgrade_progress.php in cache/upgrades/temp looks by the way like this:

<> ?php
// created: 2020-02-13 12:32:26
$upgrade_config = array (
1 =>
array (
‘upgrade_vars’ =>
array (
2 =>
array (
‘upload’ => ‘in_progress’,

I got it figured out…

I had renamed upload/upgrades/patch to upload/upgrades/patch_bkp, but this did not stop the UpgradeWizard/uw_utils.php from trying to read that directory… Moving upload/upgrades/patch_bkp completely away did the job, and now I think I have a succesfully upgraded system even if the upgrade-wizard timed out after the last step…

Is there a way to verify that an upgrade has been succesful? It bothers me now that the upgrade did not finish with the last page of the upgrade wizard. About->Version gives me the right numbers, and i have not (yet) bumped in anytihing that would be broken…

Can btw an upgrade be done from the command line, or does it always need to be done via the UI?

There is a Robo task to run a silent upgrade.

The About version is trustworthy, your upgrade concluded. The problem showing the final page is the same as the initial problem, it just fails while deleting cache/upgrades/temp at the end. This is all fixed in the next version, sorry about all the trouble you had.

Thanks! I will have a look at Robo task :slight_smile:

Now it’s time to wait for any new upgrade to test how the upgrade will work next time :- )

Hurrary! The upgrade from .11 -> 12 worked like a charm! Great work guys! :slight_smile: