Checkboxes Missing

I need some help please. We just installed the newest version. We are now trying to setup the outgoing emails. But there is the SMTP AUTH checkbox missing at all. Also some other checkboxes are missing.

Please be specific telling me in which screens you are missing checkboxes.

Do you see a lot of labels showing as “undefined” in several screens?

I would start by checking that you set your ownerships/permissions correctly, this is usually the cause for undefineds and missing screen elements in new installations.

Please find enclosed a screenshot.

I had the problem, that I was seeing a lot of fields as “undifiend” . I set the permissions to 777 and this problem was solved. Now I only have some of the checkboxes missing.

Thank you for helping me

After correcting the permissions, you need to run a Admin / Quick Repair and Rebuild, and possibly some other Javascript Repairs from that screen.

I definitely do not advise 777 permissions, they are completely unsafe.

Thank you. I will set permissions on all to 755 / exept cache, custom, modules, themes, data, upload and config_override.php - these will be 775
i will report.

then I will run quick repair in admin and will report :slight_smile:

I have changed permissions. and run the repairs in admin… but no change… the checkboxes are still missing. Do I have to change ownership and if yes, could you please let me know how. I need to say, that I´m not a developer. Thank you

Checkboxes on which Screen. If you have changed perms, that would be enough to allow apache read and run the files.

Please have a look at the above screenshot. I´m struggeling with set the setttings for outgoing emails. All other items are running fine so far, but the checkbox SMTP AUTH is missing in screen admin - > email settings.

In your Browser console (press F12 to see the Developer Panel and then Click on Console Tab) do you see any errors for this page when its loaded?
Make sure that cache/themes/SuiteP/css/style.css is completely loaded.
another area would be to allow EmailMan module with 775 access.

What if you change to English language? Do you still face the same issue?

I just checked. There are no erros in console tab. I have changed into English as well and there is the same problem.
I will try Emailman module with 775 access

Make sure that cache/themes/SuiteP/css/style.css is completely loaded.
( can you help me with this )

Thanks for all the help. I really apreciate this

I have checked the permissions for Emailman Modul and its allready set to 775…

Don’t forget ownership…

So, if you go in Admin / Schedulers, at the bottom you will find instructions to set up crontab. There you will see the user name that your web server is running under (right after “crontab -e -u ____”).

That’s what you need to use in the “chown -R” command as described here

hi there. I only have access to my webspace via ftp. Could you please help me doing this …by steps. I really don´t want to bother you, but we would like to start working with the crm this week, we have allready imported all data, clients and contact. And It works fine for us, but we can´t work without configure the emails.
Thank you !!!

I really wouldn’t advise you to run a CRM in a company with a web hosting that doesn’t allow you to use an SSH shell to give commands. Even very cheap hostings will allow this, if you select the right one.

And specifically SuiteCRM is a system where you often solve problems from the command-line…