Changes to php.ini have zero effect - don't save

Changes to php.ini have zero affect. I changed the like 4-5 suitecrm recommended values so I could upgrade Suitecrm.

Changed the 4-5 recommended values in /etc/php/7.0/apache2/php.ini

I change and then restart apache.
systemctl stop apache2
systemctl start apache2

Then do another suitecrm diagnostics - no change to in memory values. Same error trying to upgrade about exceeding 52M

This is a recent Univention vmware install which works - just can’t upgrade now.

I don’t have php-fpm nor ngnix.

Seems like the normal php.ini has been circumvented somehow by these Univention people.

post_max_size and upload_max_filesize, also check for .user.ini (set as user_ini.filename in php.ini) in the suitecrm folder, and settings of php_value in .htaccess.

You can get phpinfo from the diagnostic tool in admin, which tells you which ini files are loaded, and so on.

So, I’ve found the crux of the issue.

This is the Univision Vmware image original install (10.7?).

They have stuck Suitecrm within a Docker container apparently to make things unbearable unless you purchase their support package.

Within the Docker container they have a file: /etc/php/7.0/conf.d/21-suitecrm.ini which contains override values for these variables.
This file is not visible in the normal filesystem as it’s overlayed by docker.
To get to it and modify it, you have to burrow into the Docker container and create a Linux shell.
I did that and modified the variables.
Same need to burrow into container to even get to the /var/www/suitecrm directory at all.

So. after changing the settings within 21-suitecrm.ini and restarting the new php values were in effect.

So, I ran the upgrade wizard.
Now it complained during upload of of missing /var/www/suitecrm/temp directory.

Burrowed into Docker container and created it with 777.

Restarted upgrade wizard upload and it got past the temp directory error.

But upload progress bar has been spinning for over 8 hours.
Nothing in temp directory.
No errors in the upgrade wizard log.

This is maddening.