Change Email sender

I have got some email problem. When I send email from my CRM system, the reciepent gets email from me not by my name but as email address. Like My name is Good Product Comp and email is

I want that recipients gets email from Good Product Comp notfrom


I am able to get the Email “Sender” to show as the Name when sending via the System Outbound Mail:

However, It seems to show the Email address when sending via the (non-system) Outbound Account specified in the User’s Inbound Mail account:

Is that similar to what you're experiencing, by chance?

If so, it seems like the CRM is perhaps inconsistent in the way it builds the “Reply_to” or “From” values, depending on where they’re saved…

for example, the System Email values are formatted like:
(With the “Name” prepended onto the “reply_to” and “from” values)

Whereas the other Inbound/Outbound values are formatted like:
(With “from” simply being the Email address, with no prepended alias)

It looks like it retrieves these values in the file:
at line ~418

But, unfortunately, I’m not currently sure how/where it saves these values.

I would recommend raising it as a bug on the Github repo, if one doesn’t exist, for now
Unless another user is aware of a possible quick-fix, or something easily missed in the CRM to enable this?

Hello John
You always the helping friend :slight_smile:

When I send any email to customers, they get email as my email address. But I want them to see as my company name. Is it a bug problem? Do you have same problem?

Hey there,

I’m not sure if its necessarily a bug, maybe more like “hasn’t been built this way”?
Although, i’m not well versed enough with the Email functionality to know for sure

I do see the issue when using a non-system Inbound/Outbound mailbox

However, it seems to be alright when I’ve selected “System” on my “Outgoing Email” when setting up my User’s Mail account:

(as a note: The “System” values are populated from the Admin->Email Settings area )

Do you get this issue if you select “System” too?
(User Profile->Email Settings->Settings->Mail Account->Edit/Add a Mail Account)