Can't upgrade from SuiteCRM 7.3.2 to 7.4.3

I found and carefully read dozens of similar postings, but none provide a resolution to the following.

The symptom is the frequently reported message:

[color=#0000ff]Specified directory ‘’ for zip file ‘upload://SuiteCRM-Upgrade-7.3.x-to-7.4.3.zip’ extraction does not exist.[/color]

System check is OK. I have tried a variety of ownership and permission settings.

Here is some additional data I have not seen in earlier posts:

The Upgrade Wizard creates the following in [color=#0000ff]suitecrm/cache/upgrades/temp[/color]


-rwxrwxrwx 1 apache  apache  185 Jan  4 15:47 upgrade_progress.php
drwxrwsr-x 2 justinm psacln 4096 Jan  5 11:47 rbPsCb

Note drwxrw[color=#ff0000]s[/color]r-x

“justinm” is our root level system username. [It is not a login name or password.]
“psacln” is the Plesk control panel Client group.

I have tried setting all SuiteCRM directory and file ownerships to justinm:psacln. This does not handle the impasse.

In manifest.php (included in SuiteCRM-Upgrade-7.3.x-to-7.4.3.zip), I have tried specifying an existing directory for “to_dir” – didn’t resolve the impasse.


...
array (
    'from_dir' => 'SuiteCRM-Upgrade-7.3.x-to-7.4.3',
    'to_dir' => '',
    'force_copy' => 
    array (
    ),
...

The temporary directory ([color=#0000ff]suitecrm/cache/upgrades/temp/rbPsCb[/color] in the example above) has a different (randomly generated) 6-character name each time I attempt to use the Upgrade Wizard, so I can’t predefine the directory’s ownership and permissions.

[size=4]Where does [color=#0000ff]Specified directory ‘’ [/color]come from (doesn’t appear to be initialized from manifest.php)?

Can/should I initialize “to_dir” with a value besides ‘’?

Is there something I can do to configure PackageManager or PHP to create a non-random temp directory?[/size]

TIA,
Steve

Check your suitecrm config.php

array (
‘dir_mode’ => 1528,
‘file_mode’ => 432,
‘user’ => ‘’,
‘group’ => ‘’,
),

The user and group must match webserver user/group (as in phpinfo)

Hope it helps.

DR