Can't Delete dashboard Tabs

Hello all. I’m hoping you can assist me.

I Can’t Delete dashboard Tabs. (Adding them is no problem.)

I have 7.1.1 installed on CentOS 6.5 64x (DigitalOcean)
php 5.5.12
all permission set to 755
user - apache
group - apache

When I run the Diagnostics Tools it hangs at 15% on the step “Getting… Database info… Database dumps… Database schema”

I’ve done a “Quick Repair” several times and logged out. Nothing helps with the tab issue.

Please help. I REALLY want to love SuiteCRM the small bugs are causing me many headaches.


Hi there,

Please run the following commands within the SuiteCRM directory:

sudo chown -R apache:apache .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php




Thank you for the reply.

I made the permissions changes.

There is NO improvement in the Tab Deleting issue.

I still can not delete any tabs.

This is REALLY irritating. SOOOO irritating in-fact.

Ive tried all browsers on OSX, Windows and iOS NONE of them can delete the tab.

THis MUST be a simple fix, What is the problem?!?!?!


i have the same problem, diagnostic tool stop at 15%

i’m on mamp pro with suitecrm 7.1

I set correctly the permission with a script file and than the tool works great!

to see the solution go to and read the post.

Why do people hijack topics! The OP’s issue was removing tabs, the subject of this forum post is the dashboard tabs. A suggestion is to start your own thread because your two issues may not even be related.

As for the removal of tabs. I am experiencing the same thing. What I have noticed:

I could not add tabs normally. Meaning I couldn’t type in the name of the tab and click on Ok. I had to press Enter to save the tab. I then had to refresh the page manually in order to see the added tab.

Now, I am trying to remove a tab and it will not leave. I press the X on the tab, the prompt comes up, I click on ok. The screen quickly refreshes and the tab is still present.

My permissions have been set as per the installation instructions found here at

to fix this bug, change line 18 of custom\modules\Home\RemoveDashboardPages.php

$html = “”;

$html = “”;

Oops, that should be:

$html = “”;

$html = “”;

Thanks for that Jeremy.

I tried implementing it and dropping the cache…I still can’t remove the tabs.



I have tried everything… unsuccessfully.

Anyway, my case is that I am making a hostile Sugar to SuiteCRM migration, and the inherited tabs I am trying to delete, are the original sugar professional tabs (version 6.4.4, without the possibility to make the upgrade to 6.5 previous to suitecrm upgrade).

Everything is working. but cannot get rid of this tabs in the home page, and when trying to delete them, get an horrible screen, without results. Permissions are OK.

Will, Is there a way to remove tabs manually by code?

Apparently I need to apologize for saying the thread was hi-jacked…I found the script that some one attempted to link to.

It is down around one third of the page. The post is by amariussi. The attachment to the post has a file in it chperms.php. Just drop that in your suitecrm directory and add the connection settings to your database…run it from a terminal or your web browser and it should fix the tab issue.

One issue down…two more to go.

Spoke too soon. It does not work.

This is a bug for sure as the issue exists in the demo. This warranted some more testing. I am using Firefox 33.1. A tab could be added, but not deleted. I tried in Chrome, 39.0.2171.65 m. I was able to remove the tab without blinking an eye. The bug is browser related.

The weird part is Firefox appears to retain the information on the tab even though it does not appear in Chrome, side by side. CTRL-F5 to refresh the Firefox display and the tab is still present. CTRL-F5 in Chrome, the tab remains gone. Clear the complete history in Firefox and the tab is now gone.

Test in IE 11.0.9600.17420. Added with no issues. Removed and tab remained. Attempted to remove again, greeted with an empty confirmation box with just an x in the top right corner. Closed it. Refreshed the page manually, the tab is gone.