Cannot upgrade from 7.10.8 to 7.10.9

I’m trying to upgrade from 7.10.8 to 7.10.9 bu everytime I upload the zip I get a blank page (HTTP error 500) reloading the page leaves me in the middle of the process, reuploading the zip starts over again with the error 500 page.
I’ve emptied the cache renamed the upload folders… it just doesn’t want to install the new patch!
Anyone has a fix?

If you have a blank screen, you should have an error message in your web server log (maybe called php_errors.log or errors.log), as defined in your php.ini.

You probably need to increase one (or more) of these settings in php.ini


(I am saying the names from memory, some might be a little different)

Those settings are set quite high!
what could be an alternative name for max execution time? this is the only setting I can’t find in my direct admin

Often people are making the changes in the wrong php.ini.

You can check your effective values, as seen by SuiteCRM, in Admin / Diagnostic, select only phpinfo and have a look.

Also, start by finding your web server log, it’s telling you what the actual problem is. It might have nothing to do with these settings. It’s quite critical to be able to check the PHP errors in your SuiteCRM installation, so it’s worth finding that even for future occasions.

1 Like

After checking everything I’ve tried to switch the php version to 7.3 and tweaked the setting and the upgrade went fine Thank you! Now I’ve another issue… it’s about the email attachments showing up in list view but not showing up in detail view, so now we can’t see attachments in the mail :frowning:

Try this change

it will be included in 7.10.10.

unfortunately it does not fix the issue… I have also noticed now that I can’t delate an email after selecting and hit delete it tells me that I’ve to select at least one … but the attachment issue has priority of course

Can you find that Issue already created on GitHub? If it isn’t there, nobody is working on it…

Please report it there if you can’t find it. Thanks

1 Like

Thank you! I’ll do that.

Hmm thanks but I wish you had filled out the template more thoroughly… we need every information we can get, don’t assume we can reproduce your bug (in this case - we can’t).

While I’m here, I’d like to ask you to please check both your logs at the moment when these screens show:

php_errors.log (or whatever your web server log is called, it’s defined in php.ini)