Cannot add Invitees to meetings or calls

I cannot add any invitees to meetings or calls, because the submit button doesn’t work. I have read about this in the forum, it seems to be an old error and I tried all the suggestions, but it still doesn’t work. This is my configuration:

  • SuiteCRM 7.11.3, running on XAMPP (all requisites are satisfied, PHP 7.1.27, etc.)
  • Tested on Windows 10 and Windows Server 2012 using Chrome, Firefox and IExplorer but the result is the same.

In the Chrome console the reported error is:

Uncaught SyntaxError: Unexpected token < in JSON at position 0
    at JSON.parse (<anonymous>)
    at Object.method_callback (sugar_grp_jsolait.js:32)
    at Object.handleTransactionResponse (sugar_grp1_yui.js?v=G9IWdl08RFn2FZ-kNIrOcQ:109)
    at sugar_grp1_yui.js?v=G9IWdl08RFn2FZ-kNIrOcQ:109 

In the IExplorer debugger, is reported an invalid character at line 32 of “sugar_grp_jsolait.js” in:

function method_callback(o){var resp=JSON.parse(o.responseText),request_id=o.tId,result=resp.result;if(result==null){return;}

in particular, the content of “o.responseText” is:

"<br />\n<b>Notice</b>:  A session had already been started - ignoring session_start() in <b>C:\\xampp\\htdocs\\SuiteCRM\\service\\JsonRPCServer\\JsonRPCServer.php</b> on line <b>99</b><br />\n{\"id\":1,\"result\":{\"list\":[]}}"

If you need other details , please write.
Thank you.

It works on 7.11.3 on the live demo, you can try it: (user will, password will)

This must be something XAMPP related. Have you turned off display_errors in your php.ini? With that on, XAMPP completely messes up SuiteCRM…

If that doesn’t solve it, check your two server-side logs.

1 Like

Thank you, the problem was the display_errors in php.ini as you said. Now it works perfectly.