Cannot add dashlets


after installation on Centos 7 / Apache 2.4.6 I am unable to add any dashlets. I am able to create new tabs but als in the new tabs I cannot add dashlets as described in another post in this forum. This is true for a regular user and an admin user.
For the rest everything works fine. I am already using this in production.

Already investigated:

  1. permissions seem to be OK (as described in installation doc) (chmod chown chgrp performed / chcon performed). All files are owned by apache with 755 and 775 as described in installation manual.
  2. SELinux: already disabled on tst system with same results.
  3. I have never touched a file in the suitecrm directory yet. So the issue with > signs as mentioned in other posts is probably not it.
  4. PHP version is PHP 5.4.16 (cli) (built: Nov 6 2016 00:29:02) and tst system PHP 5.6.19 (cli) (built: Mar 19 2016 19:37:46)
  5. Mariadb version is latest stable from Mariadb (10.1.20) tst system: 10.2.3

The only change from suitecrm default is that I changed the dir name to crm instead of suitecrm (custom install in the installation doc)
Also the system is accessed via https. I did adapt the server string in the appropriate config file as described. on the tst system same result with http access.

Any help appreciated.



during install the config.php was not created because of SElinux enabled and the installer suggested to create it manually with cut & paste from the browser window which i did. It turns out that this contents is different from what the installer creates if it creates the config.php file itself on the file system. I did an install on a test system, copied and adapted the config.php file to the production system and after this adding dashlets worked fine.