Campaign Module Internal Server Error

After installing SuiteCRM 7.7.3 the other day I noticed that the campaign module seems to have an issue. Everything else is working fine as far as I can tell (after applying a fix to the cal.js file to fix a display problem in the calendar).

When I try to create a new campaign and choose any of the campaign buttons (Newsletter, Email, non-email based campaign) I get the error message below.

I have checked the permission and verified they are as follows:

sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

I appreciate any help solving this issue.


check you .htaccess configuration, change it to 644 and make sure that you have activated in your apache configuration, plus check your logs, there’s always something there.

best regards

@mikebeck thanks for your response. I ran chmod 644 .htaccess and verified that AllowOverride All was set for the root web directory of the install. I still get the same error when trying to access the campaign module.


did you check your logs? can you post your SuiteCRM version and System configuration, php, mysql, etc?

best regards

I received the following entries to the error.log when trying to create a new campaign.

[Fri Sep 02 18:07:04.010621 2016] [fastcgi:error] [pid 12442] (104)Connection reset by peer: [client *.*.*.*:53658] FastCGI: comm with server "/var/www/clients/client0/web5/cgi-bin/php5-fcgi-*-80-crm.*****.com" aborted: read failed, referer: http://crm.*****.com/index.php?module=Campaigns&action=EditView&return_module=Campaigns&return_action=DetailView
[Fri Sep 02 18:07:04.059134 2016] [fastcgi:error] [pid 12442] [client *.*.*.*:53658] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client0/web5/cgi-bin/php5-fcgi-*-80-crm.*****.com", referer:

I am running
suitecrm 7.7.3
PHP 5.5.9-1ubuntu4.17
mysql Ver 14.14 Distrib 5.5.49, for debian-linux-gnu (x86_64) using readline 6.3

check this post

do you have your server setup as is in the documentation here?

take a look at this section

best regards


Thanks for your help. This is going to take a while. I had the settings in my php.ini as per a previous install guide. They were not as high as you recommended so I increased them. Still no luck. I decided to check the settings via php-info file and they do not match what I have in my php.ini file. I verified the path to the file that is being used to be the same as the file I am making changes to but for some reason the changes are not being upated.

I am going to have to spend some time looking into why I am not seeing the updated settings. Hopefully this turns out to be the issue.

Thanks for your help. I will post an update once I figure out what is happening.

OK. I am really frustrated. I spent a ton of time trying to track down the problem with my php.ini settings not updating even though I had clearly edited the file that php-info was reporting as the file that it was using.

While troubleshooting I changed the name of the php.ini file to php.bak in order to verify it was not using the file. I then ran php-info expecting it not to work since the config file had been disabled. WRONG. It worked just as before with the exact same settings and the Loaded Configuration File showed NONE.

So php-info reported that there was no configuration file yet php was still working and had all the original settings. I finally found someone who had a similar issue and was pointed in a direction that solved that issue.

Turns out there was a syntax error in the php.ini file. When php parsed the file and got to the syntax error it stopped and did not throw any error. I still don’t know what file it used for the settings it did use.

To finally figure out that there was a syntax error I need to use php to parse the php.ini file because it would show any errors.

Move into the directory where php.ini resides and run the following:

$ php -a

php > parse_ini_file("php.ini");

This showed that there was a syntax error. Once the error was corrected the php.ini settings finally took and I was back to trying to figure out what was going on with the campaign module.

After many failed attempts I decided that possibly having the php.ini wrong during install caused some issue so I downloaded the new version 7.7.4 and made a clean install. I went to the campaign module and tried to create a new campaign and got another error.

The crm.*****.com page isn’t working

crm.*****.com didn’t send any data.

I am completely stumped. Now in addition to the campaign module not working the calendar module is throwing errors as well.

Notice: Undefined property: FP_events::$rel_users_table in /var/www/clients/client0/web5/web/modules/Calendar/CalendarActivity.php on line 188

Notice: Undefined property: Task::$rel_users_table in /var/www/clients/client0/web5/web/modules/Calendar/CalendarActivity.php on line 188

Notice: Undefined index: LBL_PREVIOUS_AGENDAWEEK in /var/www/clients/client0/web5/web/modules/Calendar/CalendarDisplay.php on line 522

Notice: Undefined index: LBL_NEXT_AGENDAWEEK in /var/www/clients/client0/web5/web/modules/Calendar/CalendarDisplay.php on line 503

The only thing I can think might be causing these issues is that my server uses ipconfig3 and it does user and groups a bit different in that the website directory is web5:client0 where web5 is the domain and client0 is the owner of the domain in ispconfig. www-data is the user and group for apache2. www-data is a member of the group client0.

In order to get everything to install I used 775 permissions on the entire web directory.

Thanks in advance for any help!