Campaign mail are not sending automatically

Check that your db credentials are correct in config.php. Ensure that your database server is running.

Also could this be a firewall issue?

Check your database config file. Add the following

bind-address =

Keep in mind that this will allow anyone to connect to your mysql server.

What config file will I need to add the code and where do I need to put the code?

You need to create a my.cnf file in /Applications/MAMP/conf/

and add

bind-address =

Then restart the mysql server.


How do I create a .cnf file?

I have added the my.cnf file. But Mamp can’t make connection with MySQL server anymore.

These are the errors in mysql_error_log.err:

170808 17:08:50 mysqld_safe Logging to ‘/Applications/MAMP/logs/mysql_error_log.err’.

170808 17:08:51 mysqld_safe Starting mysqld daemon with databases from /Applications/MAMP/db/mysql56
error: Found option without preceding group in config file: /Applications/MAMP/conf/my.cnf at line: 1
Fatal error in defaults handling. Program aborted

170808 17:08:51 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/ ended

Have you tried copying on of the standard files from the /Applications/MAMP/Library/support-files/ directory and restarting your mysql server?

You mean editing a copy of this file:

For advice on how to change settings please see

*** DO NOT EDIT THIS FILE. It’s a template which will be copied to the

*** default location during install, and will be replaced if you

*** upgrade to a newer version of MySQL.


Remove leading # and set to the amount of RAM for the most important data

cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.

innodb_buffer_pool_size = 128M

Remove leading # to turn on a very important data integrity option: logging

changes to the binary log between backups.


These are commonly set, remove the # and set as required.

basedir = … <= [color=#bb0000]What goes here?[/color]

datadir = …<= [color=#bb0000]What goes here?[/color]

port = … <= [color=#bb0000]8889? Default port?[/color]

server_id = …<= [color=#bb0000]What goes here?[/color]

socket = …<= [color=#bb0000]What goes here?[/color]

Remove leading # to set options mainly useful for reporting servers. [color=#bb0000]Should I just remove the #? From join… till read?[/color]

The server defaults are faster for transactions and fast SELECTs.

Adjust sizes as needed, experiment to find the optimal values.

join_buffer_size = 128M

sort_buffer_size = 2M

read_rnd_buffer_size = 2M



If that works, try and add the bind-address = * to the end of the file

Remember to restart your mysql server.

Great that worked! Should cron be running now as well?

Yes, the cron service needs to run for the campaign and other schedulers to work.

Yes, the cron service needs to run for the campaign and other schedulers to work.

I think the cron doesn’t activate the php file, my campaign isn’t running. Even when I hit the button ‘send as test’ nothing happens.

I am having a similar issue, if anyone can help please? I didn’t understand most of what is written above and I have never had to edit or create any code in SuiteCRM to make it do its thing before.

Firstly, I have successfully sent campaign emails before so I know it used to work. Not sure what has changed.
I can send emails to clients and do so all the time.
When I sent a test email from the campaign it works flawlessly.
My Crontab is setup
I have changed all my permissions to 777
I have done a quick repair and cleared my browser cache

When I click on the “Send mail at scheduled time” I get the “Emails Scheduled” confirmation but nothing happens. All the emails are still in the queue.

I am getting this error…

[Tue Aug 15 00:00:07 2017] [error] [client MYIPADDRESS] [client MYIPADDRESS] ModSecurity: Warning. detected XSS using libinjection. [file "/services/mod_security-rules/12_asl_adv_xss_rules.conf"] [line "37"] [id "341256"] [rev "2"] [msg " WAF Rules: Possible Cross Site Scripting attack (detectXSS)"] [data "11196,ARGS:mce_0"] [severity "CRITICAL"] [hostname ""] [uri "/SuiteCRM/index.php"]

Please someone, I have wasted enough time on this stupid problem!