Calendar pop up to schedule meeting or call not working


I have just uploaded my customised suite cdm package to an online server, most is working except the calendar popup.

When a date is clicked on, the popup does appear but the title just says “Loading…” and the rest of the form fails to materialise.

I have tried changing permissions but that didn’t work.

Any ideas?


Hi there,

What is your Server/PHP/MySQL setup? Have you attempted to view the console log for any javascript/client side errors?(Ctrl+Shift+J in Chrome/Ctrl+Shift+K in Firefox).



I’m using 1and1, i have added a .htaccess file to make php5 work.

I tried the javascript console and it gave me this:

Uncaught TypeError: Cannot read property ‘repeat_intervals’ of undefined index.php?module=Calendar&action=index&view=day&hour=0&day=8&month=7&year=2014:736
toggle_repeat_type index.php?module=Calendar&action=index&view=day&hour=0&day=8&month=7&year=2014:736
CAL.reset_repeat_form Cal.js?v=QOljqCGRYQNk6KzDcYPaGA:153
CAL.repeat_tab_handle Cal.js?v=QOljqCGRYQNk6KzDcYPaGA:168
CAL.load_create_form Cal.js?v=QOljqCGRYQNk6KzDcYPaGA:210
CAL.dialog_create Cal.js?v=QOljqCGRYQNk6KzDcYPaGA:223
(anonymous function) index.php?module=Calendar&action=index&view=day&hour=0&day=8&month=7&year=2014:459
n sugar_grp1_yui.js?v=QOljqCGRYQNk6KzDcYPaGA:25

OK so it’s definitely to do with the javascript, other things are not working all over the crm because of it.
I ran the javascript console with other problems and found this: 403 (Forbidden)

So it’s not finding that file which must be the problem, but I don’t know why as I have changed the permissions!!

18 months ago you got to where I am but never finished. So frustrated, it’s almost working but still can’t eliminate the “undefined” in some areas. It’s not accessing the language file because permissions are so helter skelter.

When I chgrp to apache (Centos) i get 500 error, i have to use the group of the domain username (on Centos Web Panel), but apparently that means I have the wrong permissions. Catch 22. Circular problem.

Is there a way to grant my user group permission?

Is there any hope that someone will even see this on such an old thread?