Bulk Delete Timeout Error

I have a database of about 800K leads and I want to delete them all. As of now, I can safely delete 650 leads at a time without any issues. However, if I try to bump that number up any higher I get the following error message.

[Tue Sep 06 18:37:35.508332 2016] [proxy_fcgi:error] [pid 1545:tid 140691870979840] (70007)The timeout specified has expired: [client] AH01075: Error dispatching request to : (polling), referer: http://suitecrm79.bitnam$

I’ve tried to find exactly where the timeout section is located, but have not been able to so far. I assume it’s somewhere in php.ini, however I could be wrong.

Does anybody know exactly where I should look to increase the timeout?



best regards

I did as instructed, and unfortunately, I am getting the same error message when I tried to delete 1300 leads from my Suite CRM database.

well you probably need to increase to a bigger number because +1000 leads can take some time

I forgot to paste the above line

best regards

I am looking to delete 30k leads uploaded, is there a better way to do it that selecting inside SuiteCRM and deleting, it is taking ages


Reminder popup is not working. I dont get mails, nor do i get pop-up

How to correct this


I know this is an old post, I just wanted the share my experience during so many Import tests.

Bulk Deleting Accounts, Contacts, Notes and possibly other objects really take significant amount of time.

You have to adjust both php.ini and httpd conf timeout parameters to get response, but for sure delete process continues to delete in the background even the foreground web screen timedout.

A suggesstion to speed up a bit(quite helps) :

a. Use Admin - Schedulers and set a time for Prune database if it did not run before. As you may know SuiteCRM does mark the objects as deleted not deletes physically when you delete from the application. So, previously deleted objects still kept in the database.

b. Then either use phpmyadmin or mysql console and Optimize the accounts, contacts, notes etc tables and also securitygroups_records table.

And try bulk deleting afterwards.