Bug with Users module in Admin

Hi guys,

We have noticed a bug in the Users module in Admin in that much of the data is missing, and some of the drop downs etc… are as well.

I would add an image but I’m not able to upload any, as this problem doesn’t exist locally.

On investigating the JS Console in Google Chrome, it seems that some of the JavaScript isn’t generating in the templates file as follows:

<script type="text/javascript" language="Javascript">
    currencies = ;
    themeGroupList = ;



Without the currencies and themeGroupList object, the onUserEditView() function doesn’t work (for instance, if I force them each as null or an empty object).

Again this works locally.

No useful errors are logged in the SuiteCRM log, nor is there anything useful in the PHP error log.

Many thanks,


I have tried with various of the latest 10.X and 8.X versions and it works everywhere.

The problem must be in your instance.

Please provide:
. your SuiteCRM version
. Operating system
. php version
. web server
. database

Have you changed something on your system lately? (for example SuiteCRM customisations, SuiteCRM upgrade, moved the crm instance to a different server or folder, Operating System upgrade, php upgrade, webserver upgrade, database upgrade, etc…)

Do you have permissions set correctly? If you don’t kno or you are just 99.9999% sure, please say so.

If you are on a Linux machine you can try the following:
. use: https://github.com/amariussi/chperms (follow the instructions)
. run chperms.php
. log into SuiteCRM as Admin
. go to Admin -> Repairs
. run all the top repairs (mainly Quick Repair and Rebuild and all the Javascript repairs) (If you have non upgrade safe customisations you will probably have to re-enter them so you should take a full back-up of your SuiteCRM system: bot files and DB)
. recommended: between each repair run the chperms.php script
. NOTE: whe you run Quick Repair and Rebuild, make sure you accept anything you may be prompted at the end of execution. Then run it again
. log out
. run chperms.php for the last time
. log back in
. Clear the browser cache (Ctrl+F5)
. try again

If your system is not on a Linux machine you can skip all the steps running chperms.php

Please report back.

PS: to upload files in the forum try to click in the diagonal between the buttons “Add File” and “Submit”.

I forgot: cool!! for the ZX81 as your profile image!

[quote=“amariussi” post=72031]I have tried with various of the latest 10.X and 8.X versions and it works everywhere.

The problem must be in your instance.

Please provide:
. your SuiteCRM version

Version 7.10.9
Sugar Version 6.5.25 (Build 344)

Google Cloud Ubuntu 18.04.01


Google Cloud

Server version: 10.1.34-MariaDB-0ubuntu0.18.04.1 Ubuntu 18.04

The version of Ubuntu was upgraded on the server. This bug existed before the upgrade.

All folders are chown-ed to www-data:www-data

All folders are chmod-ed to 0775

Thanks, I will try it today.


Hi amariussi,

I have run your PHP script as described in your answer. I still have the same issues as in the template is not building the JS correctly.

Many thanks,


Have you tried also the Repairs (Quick Repair and Rebuild as well as all the Javascript and JS repairs)?

Yes, I have tried all repairs.

Many thanks,


I have resolved this issue by RM the whole folder on the server and starting again with a fresh GIT clone.

The thing that I did differently was to create users first rather than importing our custom modules etc…



I’ve had word from SalesAgility HQ and the issue appears to be with the config override. I assume this will be fixed in a future version but if anyone has the same issue then avoid using the config_override.php file.