$bean_name error when importing accounts - please help

I have been trying to import accounts from a .csv file. I transferred the information to the template with the appropriate names as the headers. When importing I get a $bean_name error after importing 100 names on the list. The list still imported but the error popped up every 100 names (I ended up with 14 duplicates on the list).

We are using version 7.9.9

The steps taken to try and rectify the issue:
-Ran a quick repair and rebuild
-Tried disabling AOD
-We have tried replacing:
$bean_name = $GLOBALS[‘beanList’][$module];
return false;
return false;
$bean_name = $GLOBALS[‘beanList’][$module];

I am still very new to using the CRM and any help would be greatly appreciated :slight_smile:

Please check both your logs at the time of the import and report back here.

This was in the error log:
[863697][1][FATAL] Caught error: stat(): stat failed for upload/import/

We have updated php upload memory and now when you try to import csv file, it gives following error: Forbidden
You don’t have permission to access /index.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Also, I have tried changing permission for index.php file to 755 and 644 and also 777 but no joy.

Linux permissions don’t mean anything except as a conjugation of 3 things:

  • the permissions on the file (those 775, etc)
  • the user trying to access the file, in this case, your Web server user acting on behalf of SuiteCRM
  • the user/group ownership of the file

I would start by checking ownership.

The recommended settings for a system where the web server user is www-data are these:

    sudo chown -R www-data:www-data .
    sudo chmod -R 755 .
    sudo chmod -R 775 cache custom modules themes data upload config_override.php