API REST v4.1 has suddenly stop to work

Hi, I need help on API v4_1,
I call the API REST, to obtain leads and their fields; before yesterday all working good and I visualize
the reults of the call , but to day I have nothing at all and also I tested the login but API not connect my page to CRM, I don't receive any response
Someone else have this problem?

Did you upgrade the instance from yesterday?

Try looking at your PHP logs on here SuiteCRM sits and that could possibly show you any 500 errors.

hi samus-aran, thanx for your answer
I read the file log but I don't see any 500 error.
I write again the API CALL, but nothing is changed.
It's very strange, because an external app that name is "integromat" work normally with CRm's API, but if
you try to call a API with php, it's like suiteCRM don't receive this call

Are you using LetsEncypt Certificates on your SuiteCRM Server?

Hi no_miss,

I don’'t remeber if my certification is subscibed with LetsEncrypt, anyway my certification isn’t expired.

At last, I’ve temporarily solved making a call with http://.
Isn’t a “clean solution” but suite don’t detect my certificates.

Good to hear you have a work around.
Accessing the site insecurely is not the best long term solution so hopefully we can help you resolve the underlying issue.

It would be great if you can confirm if the server SSL Certificate is provided by LetsEncrypt.

The LetsEncrypt DST Root CA X3 root certificate expired on September 30 2021, around the same time your problem first occurred.

There is evidence of sites with valid, in date certificates experiencing the same error as you when connecting with curl, php etc

In our experience these can be solved with a client software upgrade.

thank you so much and sorry if I respond so late.
I’ll try this solution beacause I’m agree with you that this workaround is a bad idea in
a production environment.

thank u