AOW not triggering on records

I’m having a problem with this workflow not triggering properly. When the event date is set to today (‘now’) this should trigger and run on events correct?

also I am running 7.1.1

try setting it to greater than or equal to, instead of equal to

Changed and tried, even with a new workflow. Still no go, its just no triggering correctly with dates. Any other ideas or reported bugs?

I did some digging and I know ‘what’ is wrong but not how to fix it… I am pretty sure it is a bug…
When setting up the workflow I selected equal to date now, it created an invalid SQL statement, this is what it created:
SELECT AS id FROM accounts LEFT JOIN accounts_cstm accounts_cstm ON = accounts_cstm.id_c WHERE accounts_cstm.event_date_c = DATE_ADD(NOW(), INTERVAL ) AND accounts_cstm.booked_video_c = ‘1’ AND accounts.deleted = 0

The problem is there is that i didn’t specify or want an INTERVAL to the date ‘now’. . . . See the problem anyone? Know how to fix it?

I was able to do a work around of setting it up equal to or greater than NOW plus 1 minute.