AOP - wrong date and time on auto email send by AOP


AOP will auto send email when new case created, user case update, contact case update. The problem is why the email auto send by the AOP, the date and time doesn’t in correct timezone?

Hi ,

You’ve had an update to your case Crashing Problem (# 1) on 2019-05-06 09:37:06:

actually should follow my timezone which is “2019-05-06 17:37:06” not “2019-05-06 09:37:06”

The date and time is correct, when send by workflow. But, it is not correct, when send by AOP.

And the date and time store in database is no in correct timezone, “2019-05-06 09:37:06”.

php -i | findstr timezone is correct timezone.

Should it be normal or there are a wrong configure? how to store correct date and time in database?

If you go in Admin / Diagnostics, and select phpinfo there, which timezone setting to you have?

If it is wrong, see the php.ini path mentioned there, and fix it in that file, then restart your web server.

There is also a timezone setting (I think it’s in Admin / System settings, or maybe in the User profile settings).

Hi pgr,

phpinfo show correct timezone.

Admin/System have no timezone setting.

User profile there are correct timezone.

Is there any solution that can fix so the date and time in auto email send by AOP is correct?

Sorry for the delay answering, I was away for a few days.

Note that it is correct for the database to hold all the dates in the GMT+0 timezone. This is by design.

So your problem (maybe it’s a bug) is just the fact that the necessary conversion to your timezone is not taking place when replacing the variable in the email template…