All Templates broken after upgrading to 8.3.0

I upgraded from 8.1.3 to 8.3.0 and now all my templates are throwing errors. I did a stepped upgrade to 8.2 then 8.3.

I was getting errors on my system settings as well but it appears that it was due to PHP 8.x so I downgraded to 7.4 but I thought 8.3.0 was compatible with php 8.x

Warning : Undefined array key “preForm” in /home/stlalarm/public_html/crm/public/legacy/cache/smarty/templates_c/%%78^78C^78CF8652%%header.tpl.php on line 45

Warning: Undefined array key “panelCount” in /home/stlalarm/public_html/crm/public/legacy/cache/smarty/templates_c/%%78^78C^78CF8652%%header.tpl.php on line 95

I even tried to create a new template using the samples and I get the same errors upon save.

I’m really stuck at the moment unable to generate quotes or invoices.

Any thoughts or help is great

I fixed it. I missed the step ./bin/console suitecrm:app:upgrade-finalize -m merge which appears to have fixed this issue

However if I go to a previous invoice the issue still remains.

I also get the following on emails

Notice : Undefined index: Emails2_EMAIL_offset in /home/stlalarm/public_html/crm/public/legacy/modules/Emails/include/ListView/ListViewDataEmailsSearchOnIMap.php on line 125

Notice : Undefined index: to in /home/stlalarm/public_html/crm/public/legacy/modules/Emails/include/ListView/ListViewDataEmails.php on line 491

did -m merge fix your issue?

I am reading that smarty 4 doesnt support php in their .tpl unfortunately it seems alot of custom plugins/modules have {php} {/php} which breaks them…

Anyone have a solution?