Advanced Search Layout Options (Display/Hide Columns) doesn't show all module fields

If I’m using the advanced search option for my Accounts module, there is the ‘Layout Options’ at the bottom of the screen that allows me to Display or Hide columns in the search result list. It’s a very handy feature however it doesn’t allow me to display/hide all my (custom) fields, some of the fields are just not in either the ‘Display Columns’ or ‘Hide Columns’ list.
I’ve checked into the details of these custom fields and it looks like there’s no difference between the fields that do show up and the ones that don’t. Could there be another reason why some fields not show up here? Is it limited to a max. number of fields maybe?

Navigate to Studio->Accounts->ListView Layout. There are columns “Default”, “Available” and “Hidden”.
The fields in Hidden column will not be visible under Layout Options in Advanced Search. Move the fields you’d require from Hidden to Available.


Thanks a lot, exactly what I was looking for!