Advanced OpenSales Settings will not save new settings

Hi Guys,

I am using SuiteCRM 7.1.4.

I have been using the system for about 3 months now. I have only started using the AOS Quotes and Invoices now. I didn’t configure the AOS and now I want to it with a different Quotes and Invoices start number. When I go into the Admin=> AOS Settings I change the starting number for quotes and invoices and after I click save and check again the fields return to a blank field without a value.

Is there a way to manually change these settings somewhere? Any insight on this matter will be very helpful.

I used filezilla to checked to permissions for the files again

config_override.php - does not exist by default but is created when modifying System Settings
cache/ and all subdirectories and files
custom/ and all subdirectories and files
data/ and all subdirectories and files
modules/ and all subdirectories and files
include/ and all subdirectories and files
upload/ and all subdirectories and files

The sample permission scheme outlined below assumes that the host system user under which the web server is running is a member of the same group in which the Sugar files and directories belong. This is the standard setup for most hosting providers. For example, if your web server is running under the user “apache” and your files belong to the “apache” group, then Sugar would require the following permissions:

775 for the directories listed above
664 for the config.php file and all files in the directories listed above

All other files can be 644 and all other directories can be 755. However, some hosting providers don’t, by default, set the file group membership to the group to which the apache user belongs. In such cases, you will need to either request your hosting provider to change the group ownership of your Sugar installation files to a group that the Apache web server is a member of, or set the file permissions to:

I still cannot the settings under AOS Settings.

Has anyone else had this problem?

Quick Repair and Rebuild

Check the Module in Studio?

Hi nbouwsma,

Thanks for your quick reply.

The Quick Repair and Rebuild did not resolve the issue. What should I check in Studio? Is there a file with these settings I could manually change?

I have the same issue.
Going into AOS Settings and changing any of the fields then clicking save does not save.
Turning on Sugar logging to debug shows nothing in the logs.
There is no database table for AOS Quote settings.

I have just fixed this on our installation.

Edit config_override.php in the root of your installation.

Add these lines to diable groups and set first quote no.

$sugar_config['aos']['lineItems']['enableGroups'] = false;
$sugar_config['aos']['quotes']['initialNumber'] = 150000;

This must be a permissions issue on config_override.php.

Sounds like the permissions for the instance are not correct, this would cause the file to not update when you click save on the AOS settings page.

if you reset the permissions correctly this should work as epected.

I’ve tried all these with the same issue as well.

What are the permission settings meant to be for the AOS folders to get this to work properly?

Is there any way to reinstall AOS to see if that fixes the problem?


did you solve this issue? How?


The web host had to make a change:

"Error 403 could be due to the mod_security issue, we have added rules exception for the rule hit,

Please retry again at your end"

That’s what they said and once they made the change it all worked fine.

1 Like

Just wanted all the folks out there to know that I too had this same issue. I could start to make a quote, or an invoice but as soon as I clicked ‘save’ it gave me the forbidden message. After trying about a million different permissions settings via cpanel on the files that should be the cause, and still not having it work, I contacted our host and copied and pasted lwliang’s reply below to them and within minutes it was fixed. in fact, they gave a bit more detail so hopefully this can be copied and pasted to all of you folks who run into this and have an even faster fix:

ModSecurity rule 350147 has been disabled for the account “_____”, please try again.

Please also note that I’m with greengeeks, I have shared hosting with a million other sites, and a dedicated IP address if that helps.

hope that helps! :slight_smile: al my invoices and quotes seem to be working alright now.