Advanced OpenDiscovery requirements

I like to try out the Advanced OpenDiscovery but its not working at the moment as every search i do doesn’t give me any results back . I guess this is normal as i dont have apache lucene, solr, tomcat installed and not aware if i have zend on my ubuntu 12.04 machine. Is there some kind of document what needs to be installed to get Advanced Opendiscovery to work? I looked around but didn’t get anywhere.



Hi Erik,

AOD uses the Zend Lucene implementation and this is packaged with the module. The search should work out of the box. It’s worth checking the schedulers to make sure that the indexing scheduler is running. Please note also that it may take AOD a while to index existing databases. This is the first release of AOD and we’re eager for feedback so if the above doesn’t help please get in touch.


Sorry new install and forgot to add the cron job, so schedulers were not working. I have beautiful results now.
Keep up the good work.


Just switched over from Sugar, and can’t find the following:

Perform Lucene Index
Optimise AOD Index

Are they supposed to be in the Schduler module?


Perform Lucene Index and Optimise AOD Index should both be in the list of schedulers. If this is not the case then these can be added with the following details:

Job Name: Perform Lucene Index
Job: Index unindexed documents
Interval: 0 0 * * *
Execute if missed checked

Job Name: Optimise AOD Index
Job: Optimise Advanced OpenDiscovery Index
Interval: 0 */3 * * *
Execute if missed checked

It’s interesting that you don’t have these, was the SuiteCRM instance upgraded from Sugar?


Hi Jim,

./modules/Schedulers/Scheduler.php is missing them. So when someone does a “Repair Schedulers”, they get removed.

YES! I got bitten by this yesterday.

[StartOfRant] :woohoo:


You are just asking for more work because you have to recreate them (and you have to search here to find out how to do it because there are no docs on it that I could find.)

I know that the Suite developers are not at fault for this as it is built into Sugar 6.5 (because some developer at Sugar has his/her head where the sun doesn’t shine!)

Fixing this should be the #1 priority of Suite’s next release.

[EndOfRant] :slight_smile:

yep got bitten too. now o wonder how to get the reschedule schedule back.

You have to create two new schedulers via the Admin, Schedulers option (there is a ‘create’ button at top of screen)

Optimise Advanced OpenDiscovery Index
Index unindexed documents

Could we just upload from original download or a backup?


The Scheduler module are there. But by doing a ‘repair’ you wiped out the entries in some table somewhere and so you have to re-create those entries by doing what I posted earlier. It’s real simple, takes two seconds to do and it works fine. (BTW, you can give the ‘job’ any name you want.)

I’m hoping that the Suite developers will fix this so it doesn’t happen again to the next person. (It isn’t their fault… it is actually ‘bad’ Sugar code/functionality.)

Hi guys,

We aim to implement a fix in future releases.



I had to kill this job as it ran for over two days. I kill the thread in linux that was running the php cron job. I now have the status as showing running but its obviously not. It did not run again the next day I believe. How do i fix this?

Similar problem here: I importet a whole lot of data into SuiteCRM (upgraded from SugarCRM) for the purpose of testing. The “Index unindexed documents”-job now says “running” for some days and “Last Successful Run: Never”. And the global search still doesn’t show any results…
Any idea, what the problem is?

I remain having problems with this module as well, i turned it off for a while and a month ago i turned it on again. After a month i ended up with 116.000 cfs files with a size of 41 to 30 mb each. I realized this as my ssd drive was running full. I really like to this module and i like to test and help to further improve this module but i need some guidance on how you want the information supplied.