7.7.5 default outgoing mail server configuration : password is not saved ?


When I configure the default outgoing mail server, I can send the “test email” without problem, BUT when I save the settings (=click on “save”) and come back to the same screen (click on Email/Email Settings from admin), I get an error message when I click on “send test email” again ( error message : “Error:SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting” ).

I have noticed that If I enter a password again, and directly click on “send test email” then it works (email has been sent). When I click on “save”, the same problem happens and I try to send a new test email… It is like the password has not been saved.

does this error only happen when you are sending the test email from within the emails settings? or does it not seem to not save it at all for the system(as in you cant use email required function like creating a new user and it sending out the generated password ?

When I create a new user the system will send out a generated password (when I click on reset password), that is OK.

The problem occurs only when I go to admin/Email/Email Settings (Configure the default outgoing mail server for sending email notifications, including workflow alerts. ) and I click on “send test mail”.

I have the same issue when I log in as admin using the portuguese language. If I log in as admin using the english language then it works.

It looks to me that this issue is related to the password field being translated or not…