7.3.1 - Issue with Layout editions on a Module builder/Studio.

Hello !

I have upgraded the DEV environment from 7.2 to 7.3.1 and i noticed that there is an issue on the Module Builder/Studio, more specifically with the Layout section.
When i tried to edit the layout of a custom module i noticed that the layout panel is freezed and is not moving when i scroll-down , looks like the CSS postion for the object was not correctly set up.

Please let me know if there is any workaournd for this since i’m not able to modify accordingly the Layout designs.

Thanks for the new version! looks great :slight_smile:


Would it be possible to attach a screenshot of the problematic Layout?
This would give us more insight into the issue.

Thanks, John

Hi John,

I could solve some part of the issue by deleting the browser cache + a repair execution. But the problem i have now is that i cannot set two fields in the same row:

Thanks !

Another thing that i have noticed is that a great portion of the changes performed on the module builder are not commited like for example: creating or modifying custom fields, editing dropdowns values, etc.

Just FYI i have deployed already the following fix proposed:

Here you have two examples of the non-commited changes:

In any custom module, lets suppose that you create a field that is composed by a dropdown which is created on the module builder context.
You can create the dropdown list and adding values with no issues, but the problem is that you cannot delete any record of that dropdown.
I press save, but when i display the list, the “deleted” value is still there.

On the Layout design, it happens a similar situation than the above one but with the panel’s label: You change the name of it , but after you save it the change is lost.

Please let me know if you need any special information about my environment,


Studio has a few issues in later revisions, We are logging these and working through them. At the moment, you may have to repeat the process of creating/editing a Custom Field and Saving a few times for it to take effect.

You may also have to Edit the Layouts and their Labels and “Save & Deploy” a few times for it to take change.

If this does not work, go to /custom/extension/modules//Ext/Language/
Are there any files in this folder that are not SecurityGroups.php files?

Thanks, John

OK John, Good luck with that, please let me know if i can help you with something.

Regarding the /custom/extension/modules//Ext/Language/ directory, no files are created there , even the SecurityGroups.php mentioned by you.


Another issue that i have noticed in the Studio is that the relations are taking a lot of time to be committed. They are performed in the end, but takes sometime and the relations builders gets like hung during this process.

Hope this info helps you.


Regarding the SecurityGroups.php files, It is fine that you do not have these, they are not relevant.

Have you ensured that your Permissions have been set Correctly?
You will also have to check that your owner/group user setting is also correct.

Also, If you have not run a Quick Repair/Rebuild in a while, please do this.

Regards, John

Hello John,

Permissions are set up correctly. Everytime that i have a problem i execute the following command:

chown -R www-data:www-data .;chmod -R 755 .;chmod -R 775 cache custom modules themes data upload config_override.php

Regarding the Quick repair, everytime that i deploy a custom module or i change a few things on studio, i execute this in order to sync the vardefs.



As I do not know your system, this may not work, but please try with sudo before each command like so:

sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Thanks, John

I execute those commands directly being logged as root ( i know that is not a good practice ).

If it helps, i can provide you access to my environment so you can check it by your own.

Just to clarify, Was it your Scrolling issue that was resolved earlier?

Also, Are you still unable to add two fields to a row?
If not, Do any errors show up in your console when trying to do so? (ctrl+shift+k in firefox)
If you check your Suitecrm.log and Sugarcrm.log files, are there any errors when trying to add the 2nd row?

Thanks, John

Hello John ,

As i mentioned in one of my previous posts , the issue of scrolling down disappeared when i deleted the browser cache + a repair execution.

The issue with the two fields in the same line is an issue coming from the Module Builder/ Studio, since if you put one field and below another one, then when you work with that layout is correctly display ( refer to screenshot for more details ).

No errors appear on the log files.

Regarding the problems on the Studio i posted one research that i have performed:

Thanks for your help!

Hi Hector,

What Resolution is your Monitor? Sometimes this can be caused by Small or Unusual Resolutions/Aspect Ratios.

Also, What Language pack are you using? I am assuming it is the built-in spanish pack?

Hello John,

I have the issue in different resolutions with different OS ( Windows and MAC ).
The package which i’m using is Spanish but in English the problem persist.

I noticed that the non-committed changes are quite frequent. Another example, in the ‘Configure Module Menu Filters’ , you have to do the same action many times.


Hi Hector,

What browser are you using for this?

I find that the Studio views work better in Firefox than in other Browsers, so it may be worth testing it in Firefox if you are using another browser.


Sorry for my late response, in the company we use Chrome. I’ve never used firefox, i will give a try but please let me know if the issue can be solvedfor chrome.


Hello! I have installed Firefox and the display issue in the Layout editor is the same.
I attach a screenshot:

My main concern now is the delay and the non-commited changes during the edition of the modules on the studio.

Please let me know if you need more details.



The issues with the changes not being saved is an issue with studio itself. It seems to occur intermittently but we now have people working full-time on sorting out issues with studio. So hopefully this will be resolved.

Although, when the issue occurs for me, simply doing the changes and re-saving solves it. There may be another small issue with permissions.
If you open your config.php file you can find :

'default_permissions' => 
  array (
    'dir_mode' => ,
    'file_mode' => ,
    'user' => '',
    'group' => '',

The best settings may differ depending on your instance/host but we recommend the following settings:

'default_permissions' => 
  array (
    'dir_mode' => 1517,
    'file_mode' => 420,
    'user' => 'www-data',
    'group' => 'www-data',