7.10.29/7.11.18: Regressions with composing emails (missing signatures, no plain text templates)

Hello all,

we currently have SuiteCRM 7.7.8 which is working okay.

We don’t use inbound mail with SuiteCRM.

I now looked into upgrading and outbound e-mail is not behaving as expected with the new versions. I tried both 7.10.29 and 7.11.18.

With both 7.10.29 and 7.11.18 I can compose and send e-mails but the signatures that are defined under User Profile -> Email Settings -> SETTINGS -> General seem to be completely ignored in the compose window. They’re not part of the e-mails that I send, either.

The 2nd issue (again with both 7.10.29 and 7.11.18) is that plain text templates don’t seem to be working. We have a couple of plain text templates. When composing an e-mail they can be selected but don’t seem to be included. Hitting the send button gives me “Please specify your message in the body”.

Using HTML templates seems to work.

I tried selecting different editors in the user profiles for composing but that didn’t make any difference for either issue.

I’m not able to identify any hints in the logfiles.

I guess we could probably live without the explicit send as plain text option for the templates but the missing signatures are quite a nuisance.

Is there anything that I’m missing?

Any hints are greatly appreciated!

Thanks and regards – Till


have a look here

Thanks for the quick reply. :grinning:

The link you gave does not quite seem to describe the issues I’m experiencing.

AFAICT there’s no layout problem. E-mail compose windows looks okay.

And the patch (https://github.com/salesagility/SuiteCRM/commit/9abbcd446e03222b40d1b02d548db316e1daebfc?branch=9abbcd446e03222b40d1b02d548db316e1daebfc&diff=unified) that’s referenced in the above forum post is already part of the sources I installed with 7.11.18.

Main problem that I’m facing is that the e-mail signatures I define never seem to be used/included anywhere.

I would still apply the second fix if I were you.

The issue with the signatures might be a bigger problem:

I don’t think this was ever working in Email module since the bigger changes in 7.9 (I just noticed you’re coming form a version before that).

I made this add-on in case you’re interested, it would let you automate signatures and make them conditional etc.

1 Like

Thanks for your answer.

In my last comment I was talking about

which apparently fixes

That’s already part of 7.11.18.

Then there seems to be

which seems to fix

I could apply that to my 7.11.18 but it didn’t make any difference.

So it looks like neither of the above is related to the issues I’m facing.

As for the missing signature: If I understand correctly this issue here describes my problem best:

Will definitely take a look. But maybe we’ll just make the signatures part of the templates. Apparently signatures aren’t used at all?

1 Like

Thanks for such a careful and detailed reply.

The new Email module in 7.9 had a troubled beginning and in impressively long-lived trail of problems afterwards. The signatures seem to have been inadvertently dropped and never made a come-back… even though it probably wasn’t that hard to add them back.

You can put them in from the Templates but (at least without my add-on) they will be invariant, always the same (not individual to the current user).

1 Like

I played around with the templates some more. Apparently only variables from the module selected via Related To are getting replaced in the e-mail. IOW you can have variables from just one module in your template.

Or am I missing something here?

I think you are right. There are a few exceptions (like grabbing assigned user names in some places).

This was actually the first thing that moved me to go look into the templating engine (I found there are two or three different ones) and creating PowerReplacer.