Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

404 Login not found SuiteCRM8

I recently decided to run a virtual machine with Debain to try to SuiteCRM8 since I couldn’t get it running on IIS.

I followed the install directions doing the permissions and everything."

I get to /#/install and run the config in when I am finished I get a red error box at the top with no text in it. If a open a new tab and try to go to /#/install it says a config has already been installed and I can’t access that page anymore.

At this point I can access /#/login but when I try to login with the username and password I setup. Nothing, in the debugger, though I notice that the login screen is trying to access /login and not passing anything through the mod_rewrite so I get a 404 error for /login.

I adjusted the apache 000-default to reflect the changes for mod_rewrite but I don’t understand why its failing here. I also logged into phpmyadmin that setup to see if everything for the database was there and it created the database and my admin user is there.

NOTE: SuiteCRM8 is installed on /var/www and is the only thing running on this virtual machine beside phpmyadmin

I have done a new virtual server and started with a fresh install of the Ubuntu server instead of a headless Debian install. I was using DietPi and swapped over.

I get the same error following all the instructions for installing SuiteCRM8. I get SuiteCRM 7.12.5 running but I can not get passed this 404 error for it trying to find /login instead of the rewrite of /#/login when you type in the login information. I can make it to my /#/index.php and I ran the /#/Install which then gets me to /#/Login where I can attempt but it fails again.

NOTE this picture is the ubuntu install freshly done

Update: After attempting a reinstall and making sure that I have ownership of all folders this install still failed to perform. I forgot to note this is 8.1.1 which I believe to be the issue. I attempted to do another IIS install but couldn’t get the rewrite to work correctly so I swapped to a XAMPP install running PHP 7.4. I was able to get the installation to do the same thing I was seeing on my Ubuntu server. the 401/404 errors because of /Login instead of the API rewrite to /#/Login.

I had tried to install 8.1.1 through the web api but since that was failing I decided to see if the headless install would perform any better. Through that I foundout that a couple of folders need some 777 permissions which was extensions, public, cache, and bin. Then the install would happen with no errors… I would still get the 404 /index or /Login error once I was able to access the website.

NOTE: The write from the API is working i can get to /#/Index which redirects me to the default /#/Login but when the login information is passed through from login to index to display the SuiteCRM home screen this is where the rewrite stops happening in 8.1.1

To make sure I wasn’t just being dumb I decided to try 8.0.0 and 8.0.1 which I was successful in deploying and being able to login to following the installation instructions provided by SuiteCRM and other guides online.

I had a similar problem exactly with 8.1.1.
I spent two days looking for problems!
It is necessary to make changes in the downloaded distribution kit in 6 files that were published June 01 here: Commits · salesagility/SuiteCRM-Core · GitHub

I will try this and report back this weekend. I spent a couple of days as well making sure it wasn’t a server-side issue. Thank you for providing this!